PAT 甲级 1129 Recommendation System

https://pintia.cn/problem-sets/994805342720868352/problems/994805348471259136

 

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

代码:

#include <bits/stdc++.h>
using namespace std;

int N, K;
int mp[50010];

struct Node {
    int val, cnt;
    bool operator < (const Node &a) const {
        return (cnt != a.cnt) ? cnt > a.cnt : val < a.val;
    }
};

int main() {
    scanf("%d%d", &N, &K);
    set<Node> s;
    for(int i = 1; i <= N; i ++) {
        int num;
        scanf("%d", &num);
        if(i != 1) {
            printf("%d:", num);
            int outnum = 0;
            for(set<Node>::iterator it = s.begin(); outnum < K && it != s.end(); it ++) {
                printf(" %d", it -> val);
                outnum ++;
            }
            printf("\n");
        }
        set<Node>::iterator it = s.find(Node{num, mp[num]});
        if(it != s.end()) s.erase(it);
        mp[num] ++;
        s.insert(Node{num, mp[num]});
    }
    return 0;
}

  终于熬过期末可以每天安心写代码 开心~~

这道题之前自己写的超时 后来看了一哈题解 用到 set 重载 "<" 还是没怎么看明白 哭唧唧 

posted @ 2019-01-19 12:09  丧心病狂工科女  阅读(215)  评论(0编辑  收藏  举报