POJ 3624 Charm Bracelet

http://poj.org/problem?id=3624

 

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

int T;
int V, N;
int v[10010], w[10010], m[10010];
int dp[20010];

void ZeroOnePack(int cost, int weight) {
    for(int i = V; i >= cost; i --)
        dp[i] = max(dp[i], dp[i - cost] + weight);
}

int main() {
    memset(dp, 0, sizeof(dp));
    scanf("%d%d", &N, &V);
    for(int i = 0; i < N; i ++)
        scanf("%d%d", &w[i], &v[i]);

    for(int i = 0; i < N; i ++)
        ZeroOnePack(w[i], v[i]);

    printf("%d\n", dp[V]);
    return 0;
}

  01 背包 

posted @ 2018-12-20 14:51  丧心病狂工科女  阅读(124)  评论(0编辑  收藏  举报