远程桌面提示:身份验证错误 要求的函数不受支持

今天在远程服务器的时候突然出现这么一个错误提示:身份验证错误 要求的函数不受支持,当时以为是服务器问题,因为我一天起码要远程3台服务器只有这一台出现问题。果断联系服务器管理员报告问题,可是服务器管理员反馈远程桌面正常。

尝试在百度搜索答案,给出的结果基本都一样。

这个解决方法来自微软官方,

按照此方法发现我的电脑中并没有“加密 Oracle 修正”这一项。

后来经过多次搜索,取证终于问题解决,解决方法给大家分享出来。

命令 regedit 打开注册表,找到路径 [HKEY_LOCAL_MACHINE]\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters

一般情况下,到了System之后就没了,缺少的可以自己创建文件夹。

然后在最底部文件夹里面新建 DWORD(32)位的。文件名 "AllowEncryptionOracle",值:2

最后点击保存就可以远程登陆桌面(如果有必要的话,需要重启一下)

到此问题完美解决。

后来在家没事想到这个问题,个人感觉应该是我使用的操作系统是GHOST安装,这种系统存在各种优化、精简很多操作、设置都不一样,才导致这种问题。

posted @ 2019-10-30 21:09  遥望星空  阅读(...)  评论(...编辑  收藏