AmazingCounters.com

java.lang.UnsupportedClassVersionError: org/openqa/selenium/WebDriver : Unsupported major.minor version 51.0

周一上班,正常打开myeclipse,随便写了一个main方法执行。发现报错了。。。

问题提示如下:

java.lang.UnsupportedClassVersionError: org/openqa/selenium/WebDriver : Unsupported major.minor version 51.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Exception in thread "main" 

 

查看错误原因发现,jdk版本不符合,so,解决方法如下:

1.选中项目右键,选择Properties。

 2.选择Java Build Path-->Libraries-->JRE System Library-->Edit...

 3.选中Alternate JRE -->Installed JREs...

 

 4.选中Sun JDK 1.6...-->选择Edit..

 5.选择自己的jdk安装路径--->给JRE重命名--->点击Finish

 

 

posted @ 2018-02-05 10:16  jacunjpg  阅读(332)  评论(0编辑  收藏