Kafka0.7运行时报错 kafka/javaapi/consumer/ConsumerConnector : Unsupported major.minor version 51.0 解决

目前中央库中 org.apache.kafka 是用jdk1.7编译的, 故跑在1.6的jvm中会报错

解决方案: 

1. 下载kafka源码, 本地sbt进行install, 编译前 java -version确认classpath中的jdk版本是1.6

2. 编译打包成功后, 进入当前kafka目录的 core/target/scala_2.8.0/, 找到kafka-0.7.2, 将此jar包通过maven install -file 或者 maven deploy -file 添加到本地或者远程私服上去即可

 

有问题请留言, 谢谢!

posted @ 2014-09-14 21:24  zhwbqd  阅读(1167)  评论(0编辑  收藏  举报