随笔分类 - MySQL
摘要:今天学完了最后一个mysql字段约束外键,做一下总结: 一、外键约束和要求 1.父表和子表必须使用相同的存储引擎,而且禁止使用临时表;2.数据表的存储引擎只能为InnoDB3.外键列和参照列必须有相似的数据类型。其中数字的长度或是否有符号位必须相同;而且字符的长度则可以不同;4.外键列和参照列必须创
阅读全文
摘要:mysql语句大全目录 1.mysql安装 2.mysql连接 3.数据库操作 1)创建数据库 2)删除数据库 3)选择数据库 4.数据表操作 1)创建数据表 2)删除数据表 3)修改表 1)修改表名 2)添加字段 3)修改字段 4)删除字段 5)修改字段类型及名称 6)修改字段默认值 7)修改表约
阅读全文
摘要:原因为输入了不正确的密码,连接数据库时输入正确的密码即可! 另外一个原因是安装MySQL后MySQL产生了一个随机密码,而登录的时候没有将随机密码填上,解决方案见:http://www.cnblogs.com/kerrycode/p/4368312.html
阅读全文
摘要:今天把一个项目和项目的数据库都下载到了本地,安装好项目和在本地配置好数据库后,在浏览器登陆项目的后台却出现了以下错误: 后来上百度搜索了好几个答案,都是讲述修改数据库密码的步骤,但是就是没有说明为什么要修改密码,修改密码为‘123456’后,打开数据库却给我弹出以下错误: 出现以上这个‘1045 -
阅读全文
摘要:我常用的工具是navicat,但是修改definer不能用工具,只能用命令行; 数据库迁移到其他服务器上,会报definer错误,修改view的definer方法如下(比如把definer改为本地的,要加上select语句): 第一种方法: alter DEFINER = 'root'@'local
阅读全文
摘要:打开wampserver->mysql->my.ini,添加或修改innodb_force_recovery = 1 然后重启所有服务就大功告成了!
阅读全文

浙公网安备 33010602011771号