PAT-A 1019. General Palindromic Number

1019. General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of ($a_ib^i$) for i from 0 to k. Here, as usual, $0 <= a_i < b$ for all i and $a_k$ is non-zero. Then N is palindromic if and only if $a_i = a_{k-i}$ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where $0 <= N <= 10^9$ is the decimal number and $2 <= b <= 10^9$ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "$a_k a_{k-1} ... a_0$". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

程序代码:

#include<stdio.h>
#include<string.h>
int isPalindromic(int ans[],int n,int b);
int ans[32];
int main()
{
	int n,b,i;
	for(i=0;i<32;i++)
		ans[i]=-1;
	scanf("%d%d",&n,&b);
	if(isPalindromic(ans,n,b))
	{
		printf("Yes\n");
	}
	else
		printf("No\n");	
	for(i=31;i>=0;i--)
	{
		if(ans[i]==-1)
			;
		else
		{
			printf("%d",ans[i]);
			if(i!=0)
				putchar(' ');
		}
	}
	return 0;
}
int isPalindromic(int ans[],int n,int b)//基底可能很大,不能用char来保存
{
	int i=0;
	if(n==0)
	{
		ans[0]=0;
		return 1;
	}
	while(n)
	{
		ans[i++]=n%b;
		n=n/b;
	}
	int j=i-1;
	i=0;
	while(i<j)
	{
		if(ans[i]!=ans[j])
			return 0;
		i++;
		j--;
	}
	return 1;
}

posted @ 2016-08-03 23:11  zkang  阅读(151)  评论(0编辑  收藏  举报