UVA796 - Critical Links(Tarjan求桥)

In a computer network a link L, which interconnects two servers, is considered critical if there are at
least two servers A and B such that all network interconnection paths between A and B pass through L.
Removing a critical link generates two disjoint sub–networks such that any two servers of a sub–network
are interconnected. For example, the network shown in figure 1 has three critical links that are marked
bold: 0 -1, 3 - 4 and 6 - 7.
Figure 1: Critical links
It is known that:
1. the connection links are bi–directional;
2. a server is not directly connected to itself;
3. two servers are interconnected if they are directly connected or if they are interconnected with
the same server;
4. the network can have stand–alone sub–networks.
Write a program that finds all critical links of a given computer network.
Input
The program reads sets of data from a text file. Each data set specifies the structure of a network and
has the format:
no of servers
server0 (no of direct connections) connected server . . . connected server
. . .
serverno of servers (no of direct connections) connected server . . . connected server
The first line contains a positive integer no of servers(possibly 0) which is the number of network
servers. The next no of servers lines, one for each server in the network, are randomly ordered and
show the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers − 1,
specifies the number of direct connections of serverk and the servers which are directly connected to
serverk. Servers are represented by integers from 0 to no of servers − 1. Input data are correct. The
first data set from sample input below corresponds to the network in figure 1, while the second data
set specifies an empty network.
Output
The result of the program is on standard output. For each data set the program prints the number of
critical links and the critical links, one link per line, starting from the beginning of the line, as shown
in the sample output below. The links are listed in ascending order according to their first element.
The output for the data set is followed by an empty line.
Sample Input
8
0 (1) 1
1 (3) 2 0 3
2 (2) 1 3
3 (3) 1 2 4
4 (1) 3
7 (1) 6
6 (1) 7
5 (0)
0
Sample Output
3 critical links
0 - 1
3 - 4
6 - 7


0 critical links

 

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=737

 

给你一个图,让你求这个图中哪些是桥,并输出;

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <map>
#include <vector>
using namespace std;
typedef long long LL;
#define N 10005
#define met(a, b) memset(a, b, sizeof(a))

int dfn[N], low[N], Time, ans;
int n, f[N];
vector<vector<int> >G;

struct node
{
    int x, y;
    bool friend operator < (node A,node B)
    {
        if(A.x == B.x)
            return A.y < B.y;
        return A.x < B.x;
    }
}a[N];

void Init()
{
    met(dfn, 0);
    met(low, 0);
    met(f, 0);
    met(a, 0);
    G.clear();
    G.resize(n+3);
    Time = 0;
}

void Tarjan(int u, int fa)
{
    low[u] = dfn[u] = ++Time;
    f[u] = fa;
    int len = G[u].size(), v;
    for(int i=0; i<len; i++)
    {
        v = G[u][i];
        if(!dfn[v])
        {
            Tarjan(v, u);
            low[u] = min(low[u], low[v]);

            if(low[v] > dfn[u])///判断是否是桥;
            {
                a[ans].x = u;
                a[ans].y = v;
                if(a[ans].x>a[ans].y)swap(a[ans].x, a[ans].y);
                ans++;
            }
        }
        else if(fa != v)
            low[u] = min(dfn[v], low[u]);
    }
}


int main()
{
    while(scanf("%d", &n) != EOF)
    {
        Init();

        int u, v, m;

        for(int i=0; i<n; i++)
        {
            scanf("%d (%d)", &u, &m);
            for(int j=0; j<m; j++)
            {
                scanf("%d", &v);
                G[u].push_back(v);
                G[v].push_back(u);
            }
        }
        ans = 0;

        for(int i=0; i<n; i++)
            if(!dfn[i])
                Tarjan(i, -1);

        sort(a, a+ans);

        printf("%d critical links\n", ans);
        for(int i=0; i<ans; i++)
            printf("%d - %d\n", a[i].x, a[i].y);
        printf("\n");
    }
    return 0;
}
View Code
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <map>
#include <vector>
using namespace std;
typedef long long LL;
#define N 10005
#define met(a, b) memset(a, b, sizeof(a))

int dfn[N], low[N], Time;
int n, f[N];
vector<vector<int> >G;

struct node
{
    int x, y;
    bool friend operator < (node A,node B)
    {
        if(A.x == B.x)
            return A.y < B.y;
        return A.x < B.x;
    }
}a[N];

void Init()
{
    met(dfn, 0);
    met(low, 0);
    met(f, 0);
    met(a, 0);
    G.clear();
    G.resize(n+3);
    Time = 0;
}

void Tarjan(int u, int fa)
{
    low[u] = dfn[u] = ++Time;
    f[u] = fa;
    int len = G[u].size(), v;
    for(int i=0; i<len; i++)
    {
        v = G[u][i];
        if(!dfn[v])
        {
            Tarjan(v, u);
            low[u] = min(low[u], low[v]);
        }
        else if(fa != v)
            low[u] = min(dfn[v], low[u]);
    }
}


int main()
{
    while(scanf("%d", &n) != EOF)
    {
        Init();

        int u, v, m;

        for(int i=0; i<n; i++)
        {
            scanf("%d (%d)", &u, &m);
            for(int j=0; j<m; j++)
            {
                scanf("%d", &v);
                G[u].push_back(v);
                G[v].push_back(u);
            }
        }

        for(int i=0; i<n; i++)
            if(!dfn[i])
                Tarjan(i, -1);

        int ans = 0;

        for(int i=0; i<n; i++)
        {
            v = f[i];
            if(v!=-1 && low[i]>dfn[v])
            {
                a[ans].x = i;
                a[ans].y = v;
                if(a[ans].x>a[ans].y)swap(a[ans].x, a[ans].y);
                ans++;
            }
        }
        sort(a, a+ans);

        printf("%d critical links\n", ans);
        for(int i=0; i<ans; i++)
            printf("%d - %d\n", a[i].x, a[i].y);
        printf("\n");
    }
    return 0;
}
View Code

 

posted @ 2016-05-16 21:04  西瓜不懂柠檬的酸  Views(227)  Comments(0Edit  收藏  举报
levels of contents