zhber
有好多做过的题没写下来,如果我还能记得就补吧

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意是给定s,枚举每个s的前缀,判断是不是由一个串重复多次组成。如果是输出前缀长度和这个串最多自我复制几次
这题还是跟bzoj1355一样……枚举每个i和i-next[i],如果能整除就输出。
#include<cstdio>
#include<cstring>
int next[1000010];
char s[1000010];
int cnt,l,len,j;
inline void pre()
{
	memset(next,0,sizeof(next));
	j=0;
	for (int i=2;i<=l;i++)
	{
		while (j>0 && s[j+1]!=s[i])j=next[j];
		if (s[j+1]==s[i])j++;
		next[i]=j;
	}
}
int main()
{
	while (scanf("%d",&l)&&l)
	{
		scanf("%s",s+1);
		pre();
		printf("Test case #%d\n",++cnt);
		for(int i=1;i<=l;i++)
		{
			len=i-next[i];
			if (i%len==0&&next[i])
			  printf("%d %d\n",i,i/len);
		}
		printf("\n");
	}
	return 0;
}

  

posted on 2014-12-14 20:22  zhber  阅读(119)  评论(0编辑  收藏  举报