zhber
有好多做过的题没写下来,如果我还能记得就补吧

 

Description

    约翰想要计算他那N(1≤N≤1000)只奶牛的名字的能量.每只奶牛的名字由不超过1000个字待构成,没有一个名字是空字体串,  约翰有一张“能量字符串表”,上面有M(1≤M≤100)个代表能量的字符串.每个字符串由不超过30个字体构成,同样不存在空字符串.一个奶牛的名字蕴含多少个能量字符串,这个名字就有多少能量.所谓“蕴含”,是指某个能量字符串的所有字符都在名字串中按顺序出现(不一定一个紧接着一个).
    所有的大写字母和小写字母都是等价的.比如,在贝茜的名字“Bessie”里,蕴含有“Be”
“sI”“EE”以及“Es”等等字符串,但不蕴含“lS”或“eB”.请帮约翰计算他的奶牛的名字的能量.

Input

    第1行输入两个整数N和M,之后N行每行输入一个奶牛的名字,之后M行每行输入一个能量字符串.

Output

 
    一共N行,每行一个整数,依次表示一个名字的能量.

Sample Input

5 3
Bessie
Jonathan
Montgomery
Alicia
Angola
se
nGo
Ont

INPUT DETAILS:

There are 5 cows, and their names are "Bessie", "Jonathan",
"Montgomery", "Alicia", and "Angola". The 3 good strings are "se",
"nGo", and "Ont".



Sample Output

1
1
2
0
1

OUTPUT DETAILS:

"Bessie" contains "se", "Jonathan" contains "Ont", "Montgomery" contains
both "nGo" and "Ont", Alicia contains none of the good strings, and
"Angola" contains "nGo".

 

坑爹的字符串处理啊……调了我好久

就是枚举每个名字可以和给定的m个字符串匹配几个,这里匹配指名字的某一个子序列等于给定的字符串

主要是读入的时候字符串长度纠结了好久……

然后扫的时候就是枚举名字和字符串,然后两个指针指着两个串当前匹配的位置,然后往后移就可以了

#include<cstdio>
struct cow{
	int len;
	char ch[1010];
}c[1010];
struct pipei{
	int len;
	char ch[101];
}p[110];
int n,m,s1,s2;
int ans[1010];
int main()
{
	scanf("%d%d",&n,&m);
	for (int i=1;i<=n;i++)
	{
		scanf("%s",c[i].ch);
		while (c[i].ch[c[i].len])
		{
		  if (c[i].ch[c[i].len]<'a')
		    c[i].ch[c[i].len]=c[i].ch[c[i].len]+32;
		  c[i].len++;
		}
	}
	
	for (int i=1;i<=m;i++)
	{
		scanf("%s",p[i].ch);
		while (p[i].ch[p[i].len])
		{
		  if (p[i].ch[p[i].len]<'a')
		    p[i].ch[p[i].len]=p[i].ch[p[i].len]+32;
		  p[i].len++;
		}
	}
	for (int i=1;i<=n;i++)
	  for (int j=1;j<=m;j++)
	  {
		s1=0;s2=0;
		while (s1<c[i].len&&s2<p[j].len)
		{
			if (c[i].ch[s1]==p[j].ch[s2])s2++;
			s1++;
		}
		if (s2==p[j].len)ans[i]++;
	  }
	for (int i=1;i<=n;i++)
	  printf("%d\n",ans[i]);
	  
}

  

posted on 2014-07-25 21:17  zhber  阅读(435)  评论(0编辑  收藏  举报