扩大
缩小

hduoj1093A+B for Input-Output Practice (V)

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27247    Accepted Submission(s): 18476


Problem Description
Your task is to calculate the sum of some integers.
 

 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

 

Sample Input
2 4 1 2 3 4 5 1 2 3 4 5
 

 

Sample Output
10 15
View Code
#include <stdio.h>
int main()
{
    int n,a,i,b,sum;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&a);
        sum=0;
        for(i=0;i<a;i++)
        {
            scanf("%d",&b);
            sum+=b;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

posted on 2012-07-21 13:14  LinuxPanda  阅读(173)  评论(0编辑  收藏  举报

导航