HDU 1003 最大子序列和

 

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 257953    Accepted Submission(s): 61290


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

 

Author
Ignatius.L

 

 


随着i不断更新maxsum的值,如果为负数,加上下一个数不论这个数是正负,和值必定比这个数下,所以置前负值为0.若全为负数,则只需保留当前最大的负数即可。

 

#include <iostream>  
using namespace std;  
int main()  
{  
    int j,i,k,n,m,t;  
    int a[100002];  
    scanf("%d",&t);  
    for (j=1;j<=t;j++)  
    {  
        scanf("%d",&n);  
        for (i=0;i<n;i++)  
        {  
            scanf("%d",&a[i]);  
        }  
        int sum=0,maxsum=-1001,first =0, last = 0, temp = 1;  
        for (i=0;i<n;i++)  
        {  
            sum += a[i];  
            if (sum > maxsum)  
            {  
                maxsum = sum;first = temp;last = i+1;  
            }  
            if (sum < 0)  
            {  
                sum = 0;temp = i+2;  
            }  
        }  
  
        printf("Case %d:\n%d %d %d\n",j,maxsum,first,last);  
        if (j!=t)  
        {  
            printf("\n");  
        }  
    }  
      
    return 0; 
}



 



 

posted @ 2016-05-14 15:49  Lawliet__zmz  阅读(125)  评论(0编辑  收藏  举报