Hdu 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 61876    Accepted Submission(s): 25787

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

 

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

 

 

Sample Output

14

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
int N,V;
int dp[1050];
int vol[1050],val[1050];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&N,&V);
        for(int i=1;i<=N;i++)
            scanf("%d",&val[i]);
        for(int j=1;j<=N;j++)
            scanf("%d",&vol[j]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++)
            for(int v=V;v>=vol[i];v--)
                dp[v]=max(dp[v],dp[v-vol[i]]+val[i]);
        printf("%d\n",dp[V]);
    }
}

  

posted @ 2017-06-22 09:21  寂地沉  阅读(144)  评论(0编辑  收藏  举报