poj-2478 Farey Sequence(dp,欧拉函数)

题目链接:

Farey Sequence

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14230   Accepted: 5624

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9
题意:问满足a/b with 0 < a < b <= n and gcd(a,b) = 1,的数对有多少个;
思路:dp[i]=dp[i-1]+n的欧拉函数;
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+2;
long long dp[N],a[N];
int get_a()
{
    memset(a,0,sizeof(a));
    for(int i=2;i<N;i++)
    {
        if(!a[i])
        {
            for(int j=i;j<N;j+=i)
            {
                if(!a[j])a[j]=j;
                a[j]=a[j]/i*(i-1);
            }
        }
    }

}
int fun()
{
    get_a();
    dp[1]=0;
    dp[2]=1;
    for(int i=3;i<N;i++)
    {
        dp[i]=dp[i-1]+a[i];
    }
}
int main()
{
    int n;
    fun();
    while(1)
    {
        scanf("%d",&n);
        if(!n)break;
        cout<<dp[n]<<"\n";
    }
    return 0;
}

 

posted @ 2016-03-13 15:08  LittlePointer  阅读(330)  评论(0编辑  收藏  举报