1050. String Subtraction (20)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

磕磕绊绊,也算过去了,加油!!


#include <iostream>
#include <map>
#include <queue>
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <stack>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <string>
using namespace std;

#include<iostream>
#include<vector>

int has[10000];

int main(){
//	freopen("C:\\Users\\Administrator\\Desktop\\in.txt","r",stdin);
	string s;
	string c;
	while(getline(cin,s)){
		memset(has,0,sizeof(has));
		getline(cin,c);
		int ls=s.length();
		int lc=c.length();
		string temp="";
		int flag=0;
		for(int i=0;i<lc;i++){
			has[c[i]]=1;
		}
		for(int j=0;j<ls;j++){
			if(has[s[j]]==0){
				temp+=s[j];
			}
		}
		cout<<temp<<endl;
	}
	return 0;
}


posted @ 2014-03-22 17:06  子田力亥  阅读(108)  评论(0编辑  收藏  举报