HDU1194_Beat the Spread!

Beat the Spread!


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4683    Accepted Submission(s): 2441

Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 
Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 
Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 
Sample Input
2
40 20
20 40
 
Sample Output
30 10

impossible


题目大意:已知一场比赛两个终于得分的和,以及两个终于得分的绝对值差。

求两个终于得分。

若没有这种两个得分。则输出impossible。终于得分不能

为负

思路:英语理解题。最基本的是读懂题意。

两个最种得分的计算方法例如以下:

a = (s+d)/2。b = (s-d)/2。

若a、b都为整数。且都大于0,则满足条件,

否则输出impossible

#include<stdio.h>

int main()
{
    int T,s,d;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&s,&d);
        int a = -1;
        int b = -1;
        if((s+d)%2 == 0)
        {
            a = (s+d)/2;
            b = (s-d)/2;
        }
        if(a>0 && b>0)
            printf("%d %d\n",a,b);
        else
            printf("impossible\n");
    }

    return 0;
}


posted @ 2015-12-11 19:20  zfyouxi  阅读(162)  评论(0编辑  收藏  举报