Ubuntu上安装gtk2.0不能安装的问题,“下列的软件包有不能满足的依赖关系”

zez@localhoss:~$ sudo apt-get install libgtk2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libgtk2.0-dev : 依赖: libgtk2.0-0 (= 2.24.23-0ubuntu1) 但是 2.24.23-0ubuntu1.1 正要被安装
                 依赖: libpango1.0-dev (>= 1.20) 但是它将不会被安装
                 依赖: libcairo2-dev (>= 1.6.4-6.1) 但是它将不会被安装
                 推荐: debhelper 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

这种问题就应该是软件源的问题,源中的版本比较低;依赖的版本号比正要安装的版本号要低导致没法安装。
只需要将原来软件源删除,用新的软件源替换一下就可以了。
做法见这里:http://wiki.ubuntu.org.cn/%E5%A6%82%E4%BD%95%E4%BD%BF%E7%94%A8%E6%88%91%E4%BB%AC%E6%8E%A8%E8%8D%90%E7%9A%84%E6%BA%90

sudo gedit /etc/apt/sources.list
写上软件源后,再刷新一下,注意一定要刷新,运行:
sudo apt-get update

posted @ 2014-10-31 09:55  陈泽泽  阅读(...)  评论(...编辑  收藏