Kruskal——继续畅通工程

Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。 
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。 

当N为0时输入结束。
 

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input

3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output

3 1 0
 大意:只是加一个是否建立的状态,把已经建立的a[i].w赋值为0再进行排序。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 5000;
int p[MAX];
struct edge{
    int s;
    int e;
    int w;
    int i;
}a[MAX];
bool cmp(edge i,edge j){
    return i.w <j.w;
}
int find(int x){
return x == p[x] ? x:p[x] = find(p[x]);
}
int main()
{
    int T;
    while(~scanf("%d",&T)&&T){
            int sum = 0;
            for(int i = 1; i <= T;i++)
            scanf("%d%d%d%d",&a[i].s,&a[i].e,&a[i].w,&a[i].i);
            for(int i = 1; i <= T;i++)
                p[i] = i;
            for(int i = 1; i <= T;i++)
                if(a[i].i == 1)
                 a[i] .w = 0;
            sort(a+1,a+T+1,cmp);

           for(int i = 1; i <=T;i++){
                int fx = find(a[i].s),fy = find(a[i].e);
              if(fx != fy){
                p[fx] = fy;
                sum += a[i].w;
              }
           }
           printf("%d\n",sum);
    }
    return 0;
}
View Code

 

posted @ 2015-03-08 19:22  Painting、时光  阅读(146)  评论(0编辑  收藏  举报