PURPOSE
-------
This note describes some of the possible reasons for ORA-12560 errors
starting the listener on Windows NT Server. The list below shows some of the
causes, the symptoms and the action to take. It is possible you will hit
a cause not described here, in that case the information above should allow
it to be identified.


SCOPE & APPLICATION
-------------------

Support Analysts and customers.


ORA-12560 STARTING LISTENER ON NT - TROUBLESHOOTING
---------------------------------------------------

ORA-12560: TNS吐舌rotocol adapter error
Cause: A generic protocol adapter error occurred.
Action: Check addresses used for proper protocol specification. Before
reporting this error, look at the error stack and check for lower
level transport errors.For further details, turn on tracing and
reexecute the operation. Turn off tracing when the operation
is complete.

This is a high level error just reporting an error occurred in the actual
transport layer. Look at the next error down the stack and process that.


1.- Starting Listener with TCP/IP Protocol

Problem:
You start the TNS Listener from command line and the TCP/IP
address fails with a TNS-12560.

Solution:
Check if Microsoft Winsock Proxy(WSP) Client is enabled on the
Windows NT Server, if that is the case then go to windows Control Panel,
click WSP icon and select the disable Proxy Client option.

Explanation:
The Winsock application may fail to bind to a specific port on a
Proxy Server computer when the Winsock is running Proxy Client.

2.- TNS-12560 TNS-512 Starting the listener.

Problem:
You try to start up the listener and receive the following error stack:
TNS-12542: TNS:address already in use
TNS-12560: TNS吐舌rotocol adapter error
TNS-00512: Address already in use
32-bit Windows Error: 48: Unknown error

Error: TNS 512
Text: Address already in use
--------------------------------------------
Cause: Specified listener address is already being used.
Action: Start your listener with an unused address.

Generally this problem may ocurr for a incorrect setting in the
listener.ora. Some causes of this problems may be:

a.- Some defined address in the listeners.ora is been used. Make sure
other listeners are not running. Either listener.log and screen output
appear the address with problem.

b.- Just for 8i: in windows NT the algorithm to acquire
the address has change, please check the Note 69026.1: Oracle 8i
and socket LISTEN operations.

Explanation:
The listener will try to acquire the address in exclusive mode, if this is
been used then the process to get it will fail.

3.- Starting the listener the errors ORA-12203,ORA-12560, NL-462 or NL-427
may be raised.

Problem:
You try to start up the listener and receive the following errors
ORA-12203,ORA-12560, NL-462 or NL-427.

Solution:
Recreate the listener.ora file.

Explanation:
Some corruption in the listener.ora may get unable to the tnslsnr to
work adequatly.


4.- Failed to start service, TNS-12560, TNS-00530 when create new listener
services

Problem:
To recreate Oracle TNS listener service on Windows NT, you delete the
service entry in registry. When using lsnrctl to start the listener,
you get the following errors:

LSNRCTL> start
Starting tnslsnr: please wait...

Failed to start service, error 3.

TNS-00530: Protocol adapter error

The Listener service is not recreated and the Listener would not start.
You are using a valid listener.ora file and protocol adapters.


Solution:
After you delete the Listener service from registry, you have to reboot NT
for it to take effect. Then you can use lsnrctl to start the Listener,
which would re-create the listener service.


Explanation:
The Listener service is marked 'disabled', but it still exists after you
delete the service from registry.