安装php的rabbitmq扩展amqp

安装rabbitmq-c库(librabbitmq)

方法一:yum install librabbitmq(这个方法目前安装的是v0.8.0版本,最新目前已到v0.9.0版本,该方法到安装amqp扩展时找不到librabbitmq路径,因此选择了第二种)

方法二:

下载

wget https://github.com/alanxz/rabbitmq-c/archive/v0.9.0.tar.gz

解压编译

#解压并进入目录
tar -zxvf v0.9.0.tar.gz
cd rabbitmq-c-0.9.0
#创建build目录并进入
mkdir build && cd build
#当cmake根据rabbitmq-c的根目录下的CMakeList.txt创建Makefile文件时,会将Makefile文件放进build目录
#下面最后的两个点不是输入错了,是确实需要的
cmake -DCMAKE_INSTALL_PREFIX=/usr/local/rabbitmq-c ..
#创建
cmake --build .  --target install
#这时如果不报错/usr/lcoal目录下已存在rabbitmq-c 

安装amqp扩展

下载解压amqp

wget http://pecl.php.net/get/amqp-1.9.4.tgz
tar -zxvf amqp-1.9.4.tg

编译

#进入目录
cd amqp-1.9.4
#执行phpize生成configure
/usr/local/php/bin/phpize

./configure --with-php-config=/usr/local/php/bin/php-config --with-amqp --with-librabbitmq-dir=/usr/local/rabbitmq-c

make

当执行make时报错

在之前的rabbitmq-c中搜索不到lib,这时进入rabbitmq-c执行 ln -s lib64 lib

然后去重新编译amqp,make通过,执行make install

修改php.ini文件

追加extension=amqp.so

 

posted @ 2019-01-17 15:12  菜鸟长成记  阅读(...)  评论(...编辑  收藏