约数的个数

Description

 

mmoaay小侄子今年上初中,老师出了一道求约数个数的题目,比如8的约数有1,2,4,8共4个。

当数比较小的时候可以人工算,当n较大时就难了。

mmoaay嫌麻烦,现在让你编个程序来算。

Input

一行一个整数。最后以0结束。

Output

分别求出这些整数的约数个数,最后的0不用处理。

Sample Input

8
100
0

Sample Output

4
9

一个知识点:任何数都可以写成2的p1次方乘以3的p2次方乘以5的p3次方……也就是素数的乘积  约数的个数是(p1+1)*(p2+1)……

AC代码

#include <iostream>
#include<stdio.h>
using namespace std;
#include <string.h>
int main()
{
    int n,i;
    while(1)
    {
        scanf("%d",&n);
        if(n==0)
            break;
        int d=1;
        for(i=2;n!=1;i++)
        {
            int c=1;
            while(n%i==0)
            {
                c++;
                n/=i;
            }
            d*=c;
        }
        printf("%d\n",d);
    }
    return 0;
}

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

题意:判断相邻的素数差最小与差最大

posted @ 2018-09-04 17:47  ~~zcy  阅读(409)  评论(0编辑  收藏  举报