PTA A1016

A1016 Phone Bills (25 分)

题目内容

A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.
For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

单词

bills

英 /bɪls/ 美 /bɪls/
n. 账单;议案(bill的复数)
n. (Bills)人名;(英、德)比尔斯
v. 开账单(bill的第三人称单数形式)

calendar

英 /'kælɪndə/ 美 /'kæləndɚ/
n. 日历;[天] 历法;日程表
vt. 将…列入表中;将…排入日程表

denoting

指示(denote的现在分词)

toll

英 /təʊl/ 美 /tol/
vt. 征收;敲钟
n. 通行费;代价;钟声;伤亡人数
vi. 鸣钟;征税

cent

英 /sent/ 美 /sɛnt/
n. 分;一分的硬币;森特(等于半音程的百分之一)
n. (Cent)人名;(法)桑

chronologically

英 /krɔnə'lɔdʒikli/ 美 /krɔnə'lɔdʒikli/
adv. 按年代地

paired

英 /peəd/ 美 /peəd/
adj. [计] 成对的;配对的
v. 使成对;配合(pair的过去分词)

alphabetical

英 /ælfə'betɪk(ə)l/ 美 /,ælfə'bɛtɪkl/
adj. 字母的;[计] 依字母顺序的

题目分析

计算花费账单,这题主要是排序和计算花费,排序可以使用qsort,我昨天还特地复习了一下,写了篇博客【C/C++】qsort函数的使用方法和细节
先根据名字顺序排序,然后在每个名字序列你根据时间排序(为了方便比较我把时间全部转化成了分钟数),排好序后先判断这个用户有没有有效记录,如果有根据是否有两个相邻且状态不同的记录,如果是就输出开始时间和结束时间计算分钟数,计算账单金额。
关于计算账单金额,看上去很简单,其实细分起来情况还是很多的,我一开始就是分情况做的,什么一个小时内的情况,一天内多个个小时的情况,跨天可是小时数不满一天,好多天的情况,这些情况都对应着一些极端数据,不考虑肯定是A不了的,弄起来很麻烦。后来我用了一个最佛系的方法,一分钟一分钟的遍历.....最后我得出一个结论,能简单解决的问题就不要分情况瞎折腾。

具体代码

    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    #define ONLINE 0
    #define OFFLINE 1

    int fare[24];

    struct record
    {
	    char user[21];
	    int min;
	    int line_char;
    };
    
    int N, M;
    struct record r[1001];

    int convert_min(int d, int h, int m)
    {
	    return d * 24 * 60 + h * 60 + m;
    }

    int compare_user(const void *p,const void *q)
    {
	    return strcmp(((struct record*)p)->user, ((struct record*)q)->user);
    }
    
    int compare_min(const void *p, const void *q)
    {
	    return ((struct record*)p)->min - ((struct record*)q)->min;
    }

    int main(void)
    {
	    for (int i = 0; i < 24; i++)
		    scanf("%d", &fare[i]);
	    scanf("%d", &N);
	    for (int i = 0; i < N; i++)
	    {
		    int d, h, m;
		    char line[10];
		    scanf("%s %d:%d:%d:%d %s", r[i].user, &M, &d, &h, &m, line);
		    r[i].min = convert_min(d, h, m);
		    if (strcmp(line, "on-line") == 0)
			    r[i].line_char = ONLINE;
		    else
			    r[i].line_char = OFFLINE;
	    }
	    qsort(r, N, sizeof(struct record), compare_user);
	    int begin = 0;
	    char* temp = r[begin].user;
	    int dayfare = 0;
	    for (int i = 0; i < 24; i++)
		    dayfare += fare[i];
	    for (int i = 0; i <= N; )
	    {		
		    if (strcmp(temp, r[i].user) != 0)
		    {
			    qsort(r + begin, i - begin, sizeof(struct record), compare_min);
			    int flag = 0;
			    for (int n = begin; n < i; )
			    {
				    if (r[n].line_char == ONLINE && r[n + 1].line_char == OFFLINE && n + 1 < i)
				    {
					    flag = 1;
					    n += 2;
				    }
				    else n++;
			    }
			    if (flag)
			    {
				    printf("%s %02d\n", r[begin].user, M);
				    int sum = 0;
				    for (int n = begin; n < i; )
				    {
					    if (r[n].line_char == ONLINE && r[n + 1].line_char == OFFLINE && n + 1 < i)
					    {
						    printf("%02d:%02d:%02d", r[n].min / (24 * 60), r[n].min % (24 * 60) / 60, r[n].min % (24 * 60) % 60);
						    printf(" %02d:%02d:%02d", r[n + 1].min / (24 * 60), r[n + 1].min % (24 * 60) / 60, r[n + 1].min % (24 * 60) % 60);
						    printf(" %d", r[n + 1].min - r[n].min);
						    int mon = 0;
						    int start = r[n].min; int end = r[n + 1].min;
						    while (start != end )
						    {
							    mon += fare[(start % (60 * 24) / 60)];
							    start++;
						    }
						    sum += mon;
						    printf(" $%0.2f\n", mon / 100.0);
						    n += 2;
					    }
					    else n++;
				    }
				    printf("Total amount: $%0.2f\n", sum / 100.0);
			    }
			    begin = i;
			    temp = r[begin].user;
		    }
		    else i++;
	    }
	    system("pause");
    }

参考博客

posted @ 2019-09-23 18:51  smile_zyk  阅读(234)  评论(0编辑  收藏  举报