ZOJ 1586 QS Network Kruskal求最小生成树

QS Network

 

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:

 


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

 

Input

 

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

 


<b< dd="">

Output

 

for each data set,output the minimum cost in a line. NO extra empty lines needed.


<b< dd="">

Sample Input

 

1
3
10 20 30
0 100 200
100 0 300
200 300 0


<b< dd="">

Sample Output

 

370

 

题意:给你一些含权值的点,以矩阵形式给你一些含权边(总权值为边权+两端点权),让你找出连接所有端点的最小生成树。

思路:kruskal。每次找当前最小边,若这条边和已有的边不构成环(并查集判断),则将其加入生成树。

 

#include<stdio.h>
#include<algorithm>
using namespace std;

int f[1005],a[1005];
struct Edge{
    int u,v,w;
}edge[500005];

bool cmp(Edge a,Edge b)
{
    return a.w<b.w;
}

int find(int x)
{
    return f[x]==x?x:f[x]=find(f[x]);
}

int kru(int c,int n)
{
    int i;
    for(i=1;i<=n;i++){
        f[i]=i;
    }
    sort(edge+1,edge+c+1,cmp);
    int cnt=0,ans=0;
    for(i=1;i<=c;i++){
        int u=edge[i].u;
        int v=edge[i].v;
        int w=edge[i].w;
        int fu=find(u),fv=find(v);
        if(fu!=fv){
            ans+=w;
            f[fv]=fu;
            cnt++;
        }
        if(cnt==n-1) break;
    }
    if(cnt<n-1) return -1;
    else return ans;
}
int main()
{
    int t,n,x,c,i,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        c=0;
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++){
                scanf("%d",&x);
                if(i<j){
                    edge[++c].u=i;
                    edge[c].v=j;
                    edge[c].w=x+a[i]+a[j];
                }
            }
        }
        printf("%d\n",kru(c,n));
    }
    return 0;
}

 

posted @ 2017-07-31 21:29  yzm10  阅读(161)  评论(0编辑  收藏  举报