一.拓扑图

 

二.网段分配

 

R1

S1/0

192.168.43.1/24

R6

F1/0

10.43.30.1/24

R2

S1/0

192.168.43.2/24

R7

F1/0

10.43.20.2/24

R3

帧中继无地址

 

F0/0

10.43.30.2/24

R4

S1/0

192.168.43.4/24

 

F0/1

10.43.40.2/24

 

F0/0

10.43.10.1/24

R8

F0/1

10.43.40.1/24

R5

F0/0

1.43.10.2/24

 

 

 

 

F0/1

10.43.20.1/24

 

 

 

R6

F0/0

10.43.10.3/24

 

 

 

本地还回地址

R1

1.1.1.1/24

R6

5.5.5.5/24

R2

2.2.2.2/24

R7

6.6.6.6/24

R4

3.3.3.3/24

R8

7.7.7.7/24

R5

4.4.4.4/24

 

 

三.配置过程

(1)帧中继部分

R4

interface Loopback0

    ip address 3.3.3.3 255.255.255.0

    ip ospf network point-to-point            使路由正常。

interface Serial1/0

    ip address 192.168.43.4 255.255.255.0

    encapsulation frame-relay                封装成帧中继。

    ip ospf network non-broadcast            配置成NBMA的网络。

    ip ospf priority 255                     使R1成为DR。接口悠闲级。

    frame-relay map ip 192.168.43.1 103 broadcast   用广播方式发送帧中继信息。静态映射。(注意:对方IP和己方DLCI

    frame-relay map ip 192.168.43.2 104 broadcast

    no frame-relay inverse-arp                 关闭自动映射。

router ospf 1

log-adjacency-changes

Network 10.43.10.0 0.0.0.255 area0

    network 3.3.3.0 0.0.0.255 area 2

    network 192.168.0 0.0.0.255 area 2

    neighbor 192.168.43.1 priority 3          NBMA的网络中,只能使用neighbor来指明邻居还可以指明邻居的优先级。

neighbor 192.168.43.2

 

R3

frame-relay switching                  配置成帧中继交换机。此命令很重要。

interface Serial1/1

    no ip address

    encapsulation frame-relay              封装成帧中继

    clockrate 128000

    frame-relay lmi-type cisco              配置帧中继的类型

    frame-relay intf-type dce                配置帧中继为DCE

    frame-relay route 103 interface Serial1/0 301    做帧中继映射

    frame-relay route 104 interface Serial1/2 401

interface Serial1/0

    no ip address

    encapsulation frame-relay

    clockrate 128000

    frame-relay lmi-type cisco

    frame-relay intf-type dce

    frame-relay route 301 interface Serial1/1 103

interface Serial1/2

    no ip address

    encapsulation frame-relay

    clockrate 128000

    frame-relay lmi-type cisco

    frame-relay intf-type dce

    frame-relay route 401 interface Serial1/1 104

 

R1

interface Loopback0

    ip address 1.1.1.1 255.255.255.0

    ip ospf network point-to-point

interface Serial0/1

    ip address 192.168.43.1 255.255.255.0

    encapsulation frame-relay

    ip ospf network non-broadcast

    ip ospf priority 3

    frame-relay map ip 192.168.43.4 301 broadcast

    frame-relay map ip 192.168.43.2 301 broadcast   

no frame-relay inverse-arp

router ospf 1

    log-adjacency-changes

    network 1.1.1.0 0.0.0.255 area 2

network 192.168.0 0.0.0.255 area 2

R2配置同R1

 

 

 

2ospf路由部分

R5

conf terminal

router ospf 1

    router-id 4.4.4.4

area 1 nssa

network 4.4.4.0 0.0.0.255 area 0

    network 10.43.10.0 0.0.0.255 area 0

    network 10.43.20.0 0.0.0.255 area 1

R6R5配置相同,R4前面配过ospf省略

 

 

(2)ripng部分

 

R7

configure terminal

router ospf 1

router-id 6.6.6.6

area 1 nssa

network 10.43.20.0 0.0.0.255 area 1 

network 10.43.30.0 0.0.0.255 area 1

redistribute rip metric 25 subnets  //RIP->ospf

router rip

version 2

network 10.0.0.0

no auto-summary

redistribute ospf 1 metric 4 //ospf->Rip

R8

configure terminal

router rip

         Network 10.43.40.0

         Network 7.7.7.0

 

此时已经可以从R8ping到帧中继的R2了。

 

二.Ospfv3

1. 首先配置帧中继

2. 配置ospfv3

3. 拓扑规划

 

 

4. 地址规划

R1

S1/0

2001:db8:43:abc::1/64

R2

S1/0

2001:db8:43:abc::2/64

R4

S1/0

2001:db8:43:abc::3/64

 

F0/0

2001:db8:43:10::1/64

R5

F0/0

2001:db8:43:10::2/64

 

F0/1

2001:db8:43:20::1/64

R6

F0/0

2001:db8:43:10::3/64

 

F1/0

2001:db8:43:30::1/64

R7

F0/0

2001:db8:43:30::2/64

 

F1/0

2001:db8:43:20::2/64

 

 

r4

configure terminal

ipv6 unicast-routing

interface Serial 1/0

     frame-relay map ipv6 2001:DB8:43:abc::1 402 broadcast

     frame-relay map ipv6 2001:DB8:43:abc::2 401 broadcast  

     frame-relay map ipv6 FE80::CE01:1EFF:FE28:0 401 broadcast             

     frame-relay map ipv6 FE80::CE02:EFF:FE60:0 402 broadcast  

 

 

R1

configure terminal

ipv6 unicast-routing

interface Serial1/0

    frame-relay map ipv6 2001:DB8:43:abc::3 202 broadcast

    frame-relay map ipv6 2001:DB8:43:abc::2 201 broadcast

    frame-relay map ipv6 FE80::CE01:1EFF:FE28:0 201 broadcast

    frame-relay map ipv6 FE80::CE04:19FF:FE18:0 202 broadcast

R2

configure terminal

ipv6 unicast-routing

interface Serial1/2

    frame-relay map ipv6 2001:DB8:43:abc::3 102 broadcast

    frame-relay map ipv6 2001:DB8:43:abc::1 101 broadcast

    frame-relay map ipv6 FE80::CE04:19FF:FE18:0 102 broadcast

    frame-relay map ipv6 FE80::CE02:EFF:FE60:0 101 broadcast

配置ospf

r4

configure terminal

ipv6 router ospf 1

    router-id 3.3.3.3

    area 0 range 2001:db8:43::/64

 

interface Serial1/0

    ipv6 ospf 1 area 2

    ipv6 enable

    ipv6 ospf neighbor FE80::CE02:EFF:FE60:0 priority 1

    ipv6 ospf neighbor FE80::CE01:1EFF:FE28:0  priority 1

 

interface fastEthernet 0/0

    ipv6 ospf 1 area 0

R2R1

R1

configure terminal

ipv6 router ospf 1

    router-id 5.5.5.5

interface Serial1/0

    ipv6 ospf 1 area 2

ipv6 enable

 

配置OSPFV3

R6参考R5配置

R5

configure terminal

ipv6 unicast-routing

ipv6 router ospf 1

    router-id 4.4.4.4

    area 1 nssa

interface fastEthernet 0/0

    ipv6 enable

    ipv6 ospf 1 area 0

interface fastEthernet 0/1

    ipv6 enable

ipv6 ospf 1 area 1

R7

configure terminal

ipv6 unicast-routing

ipv6 router rip ys

redistribute ospf 1 metric 4

  redistribute connected

ipv6 router ospf 1

router-id 6.6.6.6

area 1 nssa

redistribute rip ys

redistribute connected

 

四.实验总结

  这次实验做的十分艰难,有许多上课做过得实验在实际做作业的时候会做不通,实际上是本身没有很好的总结上课的内容,表面上做通做会了,实际上没有深刻了解其中的原理和其他的应用方法,导致拓扑稍微复杂或者变动就不会了。

  这次作业体验最深的是帧中继那部分,并没有通过配置ip地址来实现报文的交换在这次实验中有很深的体会。同时这次作业在查错的时候以外的更加了解了route-id的决定原理以及手动添加变更删除route-id的指令。

  同时还是不太了解路由汇总与重发布的具体作用以及意义,只是知道大致的配置与作用,会在这次作业之后好好研究。