解决netaddr不能安装0.7.6以上版本

今天在Jenkins上添加了两个新jobs,但是同事提交代码后的自动测试运行出现错误。查看原因是tox命令在安装包依赖的时候,找不到大于0.7.6以上的版本,但可是我们明明安装过0.7.10了呀。

 

后来我们发现pip会从三个地址去找pip包,首先是github,超时之后再去googlecode上找。问题就出在这里,googlecode上最新版本只有0.7.4。

 

那为什么会连接github.com超时?原来是这个域名对应的ip地址发生变化了。而我之前把github的域名写到了hosts文件里去,因为前段时间github被dns污染了。

 

好吧,这该死的原因!

posted @ 2013-11-26 14:40 牛皮糖NewPtone 阅读(...) 评论(...) 编辑 收藏