Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31165    Accepted Submission(s): 14464


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2 10 20
 

Sample Output
7 19
 

         还记得那个奇妙的斯塔林公式吗?


         直接就是公式了!


#include<cstdio>
#include<cstring>
#include<cmath>
#define pi acos(-1.0)
using namespace std;
int n;
int solve()
{
	return (int)((n*log(n)-n+(log(2*pi*n))/2)/log(10))+1;
}
int main()
{
	int N;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d",&n);
		int t=solve();
		printf("%d\n",t);
	}
	return 0;
}


posted on 2017-05-25 18:47  yutingliuyl  阅读(306)  评论(0编辑  收藏  举报