Mac下go语言goclipse插件安装部署

Try using this URL as a Eclipse Software Site:https://raw.githubusercontent.com/GoClipse/goclipse.github.io/0.16.0/releases/

It should allow you to install 0.16.0 (or a diff version if you change the URL)

地址:http://stackoverflow.com/questions/39228197/how-install-older-goclipse-version-cannot-install-goclipse-16-1-on-eclipse-4-5

说在前面:

博导让我学docker,看看docker源码,还要学学go语言,想先装环境试试。网上百度了半天想找个Eclipse插件链接,就没有一个是成功的,博客全是复制的别人的。最上面的那个是可用的URL。看来还是需要强大的Google。希望需要在Eclipse安装插件的朋友方便使用。

Try using this URL as a Eclipse Software Site:https://raw.githubusercontent.com/GoClipse/goclipse.github.io/0.16.0/releases/

It should allow you to install 0.16.0 (or a diff version if you change the URL)

地址:http://stackoverflow.com/questions/39228197/how-install-older-goclipse-version-cannot-install-goclipse-16-1-on-eclipse-4-5

 

安装步骤:

  • 步骤非常简单
  • 第一步:
  • 选择GoClipse即可,需要等待5分钟左右即可安装完毕。
  • 需要注意的是该方法需要java8,如果是java7的,需要更新到java8即可,要不然Eclipse会启动时提醒报错。当然还可以使用liteidex30.2.macosx-qt5,也是不错的编译器,轻量,安装方便。

第二步:配置bash_profile 

  

    要注意的是:GOPATH和GOROOT的区别:GOPATH是你的工作目录,而GOROOT是GO语言的源码的安装目录。

 

第三步,就是需要配置Eclipse的环境

1、选择偏好设置

2、先配置好goroot和工作环境

3、再配置其他的配置

主要前三个 需要按download进行下载。最后一个gofmt在goroot目录下。

 

大功告成啦,我们来跑一个例子:

package main
import (
    "fmt"
)
func main() {
    fmt.Println("hello world")
}

结果

不过最最最重要的一个,千万要记住!eclipse的工作目录一定要在:gopath/src/yourproject里面,很多人如果不注意,就会遇到“Resource doesn't have a corresponding Go package" 的错误。如下图所示:

 

 

-------------原创博客,转载请注明出处,邮箱yusen.wu08@gmail.com-------欢迎翻墙过来交流--------

 

posted on 2016-09-10 20:23  Mereyct  阅读(2202)  评论(0编辑  收藏

导航

统计