最长公共子序列 poj1458

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30423   Accepted: 11856

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

问题分析: 经典的DP问题。

输入串a与串b;

Dp[i][j]表示a串中1~i与b串中1~j的子串的最长公共子序列。

                 Max{dp[i-1][j], dp[i][j-1]}       (a[i]!=b[j])

Dp[i][j]=

                 Dp[i-1][j-1]+1           (a[i]==b[j])

 

最后,a,b的最长公共子序列为dp[strlen(a)][strlen(b)]

 

代码实现:

 

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
char a[1000];    
char b[1000];
int dp[1000][1000];              //dp[i][j] is a[1~i] and b[1~j]'s common string's longest lenth
int main(){
    while(scanf("%s",a+1)!=EOF){  //cin one of the string
         scanf("%s",b+1);     //cin the other
         int lena=strlen(a+1);
         int lenb=strlen(b+1);
         for(int i=0;i<=lena;i++){
                 dp[i][0]=0;
                 }
         for(int j=0;j<=lenb;j++){
                 dp[0][j]=0;
                 }
         for(int i=1;i<=lena;i++){
                 for(int j=1;j<=lenb;j++){
                         if(a[i]==b[j]){
                            dp[i][j]=dp[i-1][j-1]+1;
                            }
                         else{
                            dp[i][j]=((dp[i-1][j])>(dp[i][j-1]))?(dp[i-1][j]):(dp[i][j-1]);
                            }
                            }
                            }
         printf("%d\n",dp[lena][lenb]);
         }
    return 0;
}

 

posted on 2012-08-31 09:03  yumao  阅读(1273)  评论(0编辑  收藏  举报

导航