优先队列实例 poj 3253

该题运用哈夫曼树,用优先队列求出两个最小的节点值,相加好push进队列中。知道队列为空为止。

 

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34



代码:
         
 
#include<iostream>
#include<queue>
using namespace std;
int main(){
    int n;
    long long a[20000];
    int flag=0;
    priority_queue<int,vector<int>,greater<int> > q;
    cin>>n;
    for(int i=0;i<n;i++){ 
          cin>>a[i];
          q.push(a[i]);
          }
    long long sum1=0;
    long long sum2=0;
    while(true){
    if(n==1){
       cout<<a[0]<<endl;
       flag=1;
       break;
       }
            int m1=q.top();
            q.pop();
            int m2=q.top();
            q.pop();
            sum1=m1+m2;
            sum2+=m1+m2;
    //        cout<<sum1<<" "<<sum2<<endl;
            if(q.empty())
                 break;
            q.push(sum1);
            }
    if(flag==0)       
         cout<<sum2<<endl;
 //   cin>>n;
    return 0;
}

posted on 2012-07-02 00:01  yumao  阅读(127)  评论(0编辑  收藏  举报

导航