随笔分类 - 【Nginx】
摘要:1.核心判断逻辑 为了避免代码冗余,可以把这套判断逻辑写成一个独立的文件(例如 cors_check.conf),然后在需要的 location 里 include 它: 文件:conf.d/cors_check.conf # 跨域精准拦截逻辑 set $cors_check ""; # 步骤A:
阅读全文
摘要:A>B的中转转发 实现访问A:8090/tgzxhd/abcd 转发到B本地:8888/abcd server { listen 8090; server_name A的公网IP; location /tgzxhd/ { proxy_pass http://B的内网IP:8080/tgzxhd/;
阅读全文
摘要:背景 后端接口地址为https://abc.com:8090/jiekou ,别的项目https://bcd.com/a 会调该接口。 默认的情况下服务器请求会提示跨域,配置所有域名又会被漏扫。 配置过add_header 'Access-Control-Allow-Origin' 'https:/
阅读全文
摘要:配置文件 #这里是启动日志以日期的方式存储 map $time_iso8601 $logdate { '~^(?<ymd>\d{4}-\d{2}-\d{2})' $ymd; default 'date-not-found'; } #日志存储路径 access_log logs/access-$log
阅读全文
摘要:当ngin不是以绝对路径启动的时候 执行make upgrade会报错找不到nginx导致更新失败解决办法 这个问题的核心原因是:make upgrade 依赖 Nginx 的「真实安装路径」与「运行时进程路径」一致,而软链接(ln -s)导致了「启动路径」和「真实路径」不统一,make upgra
阅读全文
摘要:1.配置文件内用户与启动nginx的文件的目录不同(未配置用户) 2。nginx的启动user要有操作数据目录的权限
阅读全文
摘要:A为外网服务器 #内网调用互联网高德地图 server { listen 8090; large_client_header_buffers 4 128k; client_max_body_size 100m; client_body_buffer_size 100m; client_header_
阅读全文
摘要:nginx抓包显示302 访问的ip端口有发生变化 踩坑 需配置 location /abc{ proxy_pass http://192.168.146.64:7118/; proxy_intercept_errors on; #捕捉错误 error_page 301 302 307 = @han
阅读全文
摘要:配置文件 location ^~ /sina/{ if ($request_uri ~ /sina/(.+)) { set $rightUrl $1; } proxy_pass http://127.0.0.1:8080/$rightUrl; } 来着这位大神https://142132.com/?
阅读全文
摘要:下载nginx包,具体版本查看Nginx官方下载地址。 wget http://nginx.org/download/nginx-1.17.10.tar.gz 一些编译安装要用到的依赖包 yum -y install gcc gcc-c++ make pcre-devel zlib-devel op
阅读全文
摘要:autoindex on; #开启目录树功能 autoindex_exact_size off; #关闭详细大小设置,用kb M G为单位表示 autoindex_localtime on; #显示时间为服务器端的修改时间 可以这样 location ~ /file { #root /file; a
阅读全文
摘要:前言 首先我们说一下整体思路,如图 每个NGINX都有个自己的IP地址,但是让他俩来共同轮流使用一个VIP,以便主(MASTER)宕机后备(BACKUP)来接替VIP来继续提供服务。这里我们用四台虚拟机,来分别代表NGINX1、NGINX2、WEB1、WEB2,WEB3忽略就好。 准备工作 关闭所有
阅读全文
摘要:首先查看一下当初安装nginx时添加的模块 [root@client1 nginx-1.15.9]# nginx -V nginx version: nginx/1.15.9 built by gcc 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) configure
阅读全文
摘要:Nginx 全能优化版部署文档 1. 下载 Nginx 源码包 具体版本查看 Nginx 官方下载地址:http://nginx.org/download wget http://nginx.org/download/nginx-1.17.10.tar.gz tar xf nginx-1.17.10
阅读全文
摘要:server1:192.168.200.113(nginx服务端) server2:192.168.200.111(Tomcat服务端) server1中nginx的配置文件 nginx.conf http{ 略 upstream tomcat_server { server 192.168.200
阅读全文
摘要:注意!!首先在nginx安装时添加--with-http_ssl_module模块,否则将会报错,后续的添加模块请参考这篇文章。 本文所提到是自建证书,要想真的还需要通过CA认证的证书才可以,可自行去购买,本文已于2020.11.19重新编辑,添加购买证书后的操作 1.自建证书: 通过openssl
阅读全文

浙公网安备 33010602011771号