problem

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:

1
team110 abcdefg332
Sample Output 2:

There is 1 account and no account is modified
Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:

There are 2 accounts and no account is modified

tip

简单字符串处理

answer

#include<iostream>
#include<vector>
using namespace std;

int N;
vector<string > v;
bool Replace(string &s){
	bool flag = false;
	for(int j = 0; j < s.size(); j++){
//		if(t[i] == '1') {
//			t[i] = '@';
//			flag = true;
//		}
//		if(t[i] == '0'){ 
//			t[i] = '%'; 
//			flag = true;
//		}
//			
//		if(t[i] == 'l'){ 
//			t[i] = 'L'; 
//			flag = true;
//		}
//		if(t[i] == 'O'){ 
//			t[i] = 'o'; 
//			flag = true;
//		}
		switch(s[j]) {
            case '1' : s[j] = '@'; flag = true; break;
            case '0' : s[j] = '%'; flag = true; break;
            case 'l' : s[j] = 'L'; flag = true; break;
            case 'O' : s[j] = 'o'; flag = true; break;
        }
	}
	return flag;
}
int main(){
//	freopen("test.txt", "r", stdin);
	cin>>N;
	for(int i = 0; i < N; i++){
		string a, p;
		cin>>a>>p;
		if(Replace(p)) {
			string aa = a + " " + p;
			v.push_back(aa);
		}
	}
	if(v.size()){
		printf("%d\n", v.size());
		for(int i = 0; i < v.size(); i++){
			cout<<v[i]<<endl;
		}
	}else if(v.size() == 0) {
		if(N == 1) cout<<"There is "<<N<<" account and no account is modified"<<endl;
		else printf("There are %d accounts and no account is modified", N);
	}
	return 0;
}

experience

  • 这种题目应该尽量复制粘贴题目中的信息,血的教训。
posted on 2018-07-24 20:48  yoyo_sincerely  阅读(294)  评论(0编辑  收藏  举报