problem

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title -- a string of no more than 80 characters;
Line #3: the author -- a string of no more than 80 characters;
Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher -- a string of no more than 80 characters;
Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year
Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

tip

  • 考察map的使用。

answer

#include<iostream>
#include<string>
#include<map>
#include<set>
#include<vector>
using namespace std;

int N, M;
map<string, set<int> > titleM, authorM, keyM, pubM, yearM;

vector<string> Explode(string s){
	string buff = "";
	vector<string> v;
	for(int  i = 0; i < s.size(); i++){
		if(s[i] != ' ') buff += s[i];
		if(s[i] == ' ' && buff != ""){
			v.push_back(buff);
			buff = "";
		}
	}
	if(buff != "") v.push_back(buff);
	return v;
}

void Query(string &q, map<string, set<int> > &m){
	set<int>::iterator itS;
	if(m.find(q) != m.end())
		for(itS = m[q].begin(); itS != m[q].end(); itS++){
			printf("%07d\n", *itS);
		}
	else cout<<"Not Found"<<endl;
}

int main(){
//	freopen("test.txt", "r", stdin);
	scanf("%d", &N);
	for(int i = 0; i < N; i ++){
		int id;
		string title, author, key, pub, year;
		scanf("%d\n", &id);
		getline(cin, title);
		getline(cin, author);
		getline(cin, key);
		getline(cin, pub);
		getline(cin, year);

		titleM[title].insert(id);
		authorM[author].insert(id);
		pubM[pub].insert(id);
		yearM[year].insert(id);
		vector<string> keys = Explode(key);
		for(int j = 0; j < keys.size(); j++){
			keyM[keys[j]].insert(id);
		}
	}
	scanf("%d", &M);
	for(int i = 0; i < M; i++){
		int num;
		scanf("%d: ", &num);
		string temp;
		getline(cin, temp);
		cout<<num<<": "<<temp<<endl;
		switch(num){
			case 1:{
				Query(temp, titleM);
				break;
			}
			case 2:{
				Query(temp, authorM);
				break;
			}
			case 3:{
				Query(temp, keyM);
				break;
			}
			case 4:{
				Query(temp, pubM);
				break;
			}
			case 5:{
				Query(temp, yearM);
				break;
			}
		}
	}
	return 0;
}

exprience

  • 熟练使用getline(), getchar(), scanf() 与printf()

  • 需要特别注意题目中出现的带有位数描述的数字,再输出时需要按位数输出。

posted on 2018-07-17 22:14  yoyo_sincerely  阅读(208)  评论(0编辑  收藏  举报