problem

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2
Sample Output:

Yes
Yes
No

answer

#include<bits/stdc++.h>
using namespace std;

int prime[100000] = {2, 3};
set<int> s;

void Prime(){
	s.insert(2);
	s.insert(3);
	int i, j, flag, ta = 2;
	for(i = 5; i < 100010; i+=2){
		for(j = 0, flag = 1; prime[j]*prime[j] <= i; j ++){
			if(i % prime[j] == 0) {
				flag = 0; break;
			}
		}
		if(flag){
			prime[ta++] = i;
			s.insert(i);
		}
	}
}

bool isPrime(int num)
{
	set<int>::iterator it;
	it = s.find(num);
	if(it != s.end()) return true;
	else return false;
}

int Reverse(int a, int d){
	vector<int > s;
	while(a > 0){
		s.push_back(a%d);
		a/=d;
	}
	int num = 0;
	reverse(s.begin(), s.end());
	for(int i =0;  i< s.size(); i++){
		num += s[i]*pow((float)d, i);
//		cout<<s[i];
	}
	return num;
}
int main(){
	ios::sync_with_stdio(false);
//	freopen("test.txt", "r", stdin);
	
	Prime();
	int N, M;
	while (cin>>N){
		if(N < 0)  break;
		cin>>M;
		
		if(!isPrime(N) || !isPrime(Reverse(N,M))) {
			cout<<"No"<<endl;
		}else{
			cout<<"Yes"<<endl;
		}
	}
	return 0;
}

experience

  • 素数晒法,背下模板。
posted on 2018-07-13 23:01  yoyo_sincerely  阅读(371)  评论(0编辑  收藏  举报