problem

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer~1~ is served at window~1~ while customer~2~ is served at window~2~. Customer~3~ will wait in front of window~1~ and customer~4~ will wait in front of window~2~. Customer~5~ will wait behind the yellow line.

At 08:01, customer~1~ is done and customer~5~ enters the line in front of window~1~ since that line seems shorter now. Customer~2~ will leave at 08:02, customer~4~ at 08:06, customer~3~ at 08:07, and finally customer~5~ at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output

08:07
08:06
08:10
17:00
Sorry

tips

answer

#include<bits/stdc++.h>
using namespace std;

#define INF 1010

int N, M, K, Q;

typedef struct {
	int begin;
	int cost;
	int time;
} Cu;

Cu cu[INF];

queue <Cu> q[22];

void Push(Cu &c){
	int Min = INF, index = 0;
	for(int i = 0; i < N; i++){
		if(q[i].size() >= M) continue;
		if(Min > q[i].size()) {
			Min = q[i].size();
			index = i;
		}
	}
//	if(q[index].size() >= M) return ;
	if(q[index].size() == 0) {
		c.time = c.cost;
		c.begin = 0;
	}
	else{
		c.time = q[index].back().time + c.cost;
		c.begin = q[index].back().time;
	}
	q[index].push(c);
}

void Pop(){
	int Min = INF, index = -1;
	for(int i = 0; i < N; i++){
		if(q[i].empty()) continue;
		if(Min > q[i].front().time) {
			Min = q[i].front().time;
			index = i;
		}
	}
	if(index == -1) return ;
	q[index].pop();
}

bool Empty(){
	for(int i = 0; i < N; i++){
//		cout<<"empty  "<<i<<" "<<q[i].size()<<endl;
		if(!q[i].empty()) return false;
	}
	return true;
}

void PrintStatus(){
	for(int i = 0; i < N; i++){
		for(int j = 0; j < q[i].size(); j++){
			cout<< " "<< q[i].front().time;
			q[i].push(q[i].front());
			q[i].pop();
		}
		cout<<endl;
	}
}

string GetTime(int t){
	int hour = t / 60;
	int minutes = t % 60;
	string temp;

	temp.push_back((hour+8)/10 + '0');
	temp.push_back((hour+8)%10 + '0');

	temp.push_back(':');
	
	temp.push_back((minutes)/10 + '0');
	temp.push_back((minutes)%10 + '0');
	return temp;
}

string Sorry(){ return "Sorry"; }

int main(){
	ios::sync_with_stdio(false);
//	freopen("test.txt", "r", stdin);

	cin>>N>>M>>K>>Q;	
	for(int i = 1; i <= K; i++){
		cin>>cu[i].cost;
//		PrintStatus();
		if(i > N*M) Pop();
		Push(cu[i]);
	}
	
	while(!Empty()){
		Pop();
	}

	for(int i = 0; i < Q; i++){
		int a;
		cin>>a;
		if(540 < cu[a].time){
			if(cu[a].begin >= 540) cout<<Sorry()<<endl;
			else cout<<GetTime(cu[a].time)<<endl;
		}else{
			cout<<GetTime(cu[a].time)<<endl;
		}
	}
	
	return 0;
}

experience

  • 模拟题,按照题意来就好,没必要想太多,注意弄清题意。
  • 边界条件,最后一个如果在17:00之前就开始了,那要服务完。
posted on 2018-07-13 21:55  yoyo_sincerely  阅读(252)  评论(0编辑  收藏  举报