problem

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city~1~-city~2~ and city~1~-city~3~. Then if city~1~ is occupied by the enemy, we must have 1 highway repaired, that is the highway city~2~-city~3~.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (&lt1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3
Sample Output

1
0
0

tips

answer

  • 并查集
#include<bits/stdc++.h>
using namespace std;

#define INF 0x3f3f3f3f
#define Max 1010
#define fi first
#define se second

int N, M, K;
int ci[Max], root[Max], rootTemp[Max];

void init(){
	for(int i = 0; i < Max; i++) root[i] = i;
}

int find(int i){
	if(root[i] != i) root[i] = find(root[i]);
	return root[i];
}

void unionSet(int i, int j){
	root[find(i)] = find(j);
}

int getNum(){
	int num = 0; 
	for(int i = 1; i <= N; i++){
		if(root[i] == i) num++;
	}
	return num-2;
}

typedef struct {
	int f, t;
} Edge;

Edge e[Max*Max];

int main(){
//	freopen("test.txt", "r", stdin);
	scanf("%d%d%d", &N, &M, &K);
	init();
	for(int i = 0; i < M; i++){
		scanf("%d%d", &e[i].f, &e[i].t);
	}
	
	for(int i = 0; i < K; i++){
		init();
		int t;
		scanf("%d", &t);
		for(int j  = 0; j < M; j++){
			if(e[j].f == t || e[j].t == t) continue;
			unionSet(e[j].f, e[j].t);
		}
		printf("%d\n", getNum());
	}
	return 0;
}

experience

  • cin cout超时……
posted on 2018-07-12 19:22  yoyo_sincerely  阅读(316)  评论(0编辑  收藏  举报