problem

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

tips

answer

#include<bits/stdc++.h>
using namespace std;

#define INF 0x3f3f3f3f
#define Max 2001

int N, M;

void NA(){cout<<"N/A"<<endl;}

typedef struct {
	string ID;
	int C,M,E;
	float A;
	int Bc, Bm, Be, Ba;
}St; 

St st[Max];
set<string> id;

bool CompC(St a, St b){
	return a.C > b.C;
}

bool CompM(St a, St b){
	return a.M > b.M;
}

bool CompE(St a, St b){
	return a.E > b.E;
}

bool CompA(St a, St b){
	return a.A > b.A;
}

char GetMin(St a){
	int Min = min(min(min(a.Bc, a.Bm), a.Be), a.Ba);
	if (Min == a.Ba) return 'A';
	if (Min == a.Bc) return 'C';
	if (Min == a.Bm) return 'M';
	if (Min == a.Be) return 'E';
}

void PrintStatus(){
	for(int i = 0; i < N; i++){
		cout<<i<<" "<<st[i].C<<" "<<st[i].M<<" "<<st[i].E<<" "<<st[i].A<<" "<<endl;
	}
}
int main(){
//	freopen("test.txt", "r", stdin);
	cin>>N>>M;
	for(int i = 0; i < N; i++) {
		cin>>st[i].ID>>st[i].C>>st[i].M>>st[i].E;
		st[i].A	= (float)(st[i].C + st[i].M + st[i].E)/3.0;
		id.insert(st[i].ID);
	}
	
	// C
	sort(st, st+N, CompC);
	for(int i = 0; i < N; i++){
		if(i > 0 && st[i].C == st[i-1].C ) st[i].Bc = st[i-1].Bc;
		else st[i].Bc = i+1;
	}
//	PrintStatus();
	// M
	sort(st, st+N, CompM);
	for(int i = 0; i < N; i++){
		if(i > 0 && st[i].M == st[i-1].M ) st[i].Bm = st[i-1].Bm;
		else st[i].Bm = i+1;
	}
//	PrintStatus();
	// E
	sort(st, st+N, CompE);
	for(int i = 0; i < N; i++){
		if(i > 0 && st[i].E == st[i-1].E ) st[i].Be = st[i-1].Be;
		else st[i].Be = i+1;
	}
//	PrintStatus();
	// A
	sort(st, st+N, CompA);
	for(int i = 0; i < N; i++){
		if(i > 0 && st[i].A == st[i-1].A ) st[i].Ba = st[i-1].Ba;
		else st[i].Ba = i+1;
	}
//	PrintStatus();
	
	for(int i = 0; i < M; i++){
		string temp;
		cin>>temp; 
		if(id.find(temp) == id.end()) NA();
		else{
			for(int i = 0; i < N; i++){
				if(temp == st[i].ID) {
//					cout<<temp<<" "<<min(min(st[i].Bc, st[i].Bm), st[i].Be)<<endl;
					cout<< min(min(min(st[i].Bc, st[i].Bm), st[i].Be), st[i].Ba) <<" "<<GetMin(st[i])<<endl;
				}
			}
		}
	}
	return 0;
}
/*
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
*/

/*
1 C
1 M
1 E
1 A
3 A
N/A
*/

experience

  • 注意并列的情况
posted on 2018-07-11 20:40  yoyo_sincerely  阅读(258)  评论(0编辑  收藏  举报