代码改变世界

Xcode5.1离线下载安装及使用iOS5模拟器进行开发调试的方法

2014-06-25 10:47  JG2014  阅读(199)  评论(0编辑  收藏  举报

 Xcode5.1默认不支持iOS5版本的模拟器开发调试,在OS X Mavericks(10.9.x)下默认只能支持iOS6.1及以上版本的模拟器,在OS X Mountain Lion(10.8.x)下默认只能支持iOS6.0及以上版本的模拟器进行开发和调试,在此条件之下的版本只能使用硬件设备进行开发调试。虽然现在低版本的iOS设备越来越少了,但是有时客户的需求可能会要求我们一定要兼容iOS5(或更低版本)及以上版本,如果我们手头找不到低版本硬件设备用于调试或者完全使用硬件设备而没有对应的模拟器版本进行调试,无异于会给我们开发调试带来不便,以下就从Xcode5.1相关软件的离线下载、安装和如何使用Xcode5.1默认不支持的低版本模拟器进行开发调试加以介绍。本文所述内容均是作者亲自实践的总结,希望能帮助到大家,但未经苹果官方确认,只作为读者参考,任何依赖于本文所导致的问题均由读者自己负责。本文为原创,转载请说明出处! 原文地址:http://blog.csdn.net/forestml2008/article/details/21714259

1. Xcode5.1及相关软件离线下载地址

    有时候使用下载工具比直接下载Xcode及相关软件速度更快,下面提供离线下载地址:

百度网盘:
http://pan.baidu.com/s/1ntrzAAH 

Xcode5.1(需使用Apple ID登录后才能下载):
http://adcdownload.apple.com/Developer_Tools/xcode_5.1/xcode_5.1.dmg 

Command Line Tools (OS X Mavericks) for Xcode5.1(需使用Apple ID登录后才能下载):
http://adcdownload.apple.com/Developer_Tools/command_line_tools_os_x_mavericks_for_xcode__march_2014/commandline_tools_os_x_mavericks_for_xcode__march_2014.dmg 

Command Line Tools (OS X Mountain Lion) for Xcode5.1(需使用Apple ID登录后才能下载):
http://adcdownload.apple.com/Developer_Tools/command_line_tools_os_x_mountain_lion_for_xcode__march_2014/commandline_tools_os_x_mountain_lion_for_xcode__march_2014.dmg 

iOS7.0模拟器:
http://devimages.apple.com/downloads/xcode/simulators/ios_7_0_simulator.dmg 

iOS6.1模拟器:
http://devimages.apple.com/downloads/xcode/simulators/ios_6_1_simulator.dmg 

iOS6.0模拟器:
http://devimages.apple.com/downloads/xcode/simulators/iphone_6_0_iphonesimulatorsdk6_0.dmg 

iOS5.1模拟器:
http://devimages.apple.com/downloads/xcode/simulators/iphone_5.1_iphonesimulatorsdk5_1.dmg 

iOS5.0模拟器:
http://devimages.apple.com/downloads/xcode/simulators/ios_50_simulator-1.dmg 

2. iOS模拟器的安装

    Xcode5.1默认支持的iOS模拟器的在线安装比较简单,只需启动Xcode5.1后打开菜单Xcode->Preferences...再点击Downloads就可以看到Components里对应的组件,包括Xcode5.1默认支持的iOS各版本模拟器,如果已经安装,则对应该行后面会显示一个对勾标识,如果还没有安装,只需要点击后面的下载箭头标识,则Xcode5.1就会自动下载和安装相应的组件,因为需要下载和安装,可能需要等待较长时间才能完成下载和安装。另外,下载的临时文件存放在/Users/<username>/Library/Caches/com.apple.dt.Xcode/Downloads目录中。

    这里主要以iOS7.0模拟器的离线安装为例进行说明,其他版本以此类推:

下载ios_7_0_simulator.dmg后打开dmg文件,可以看到安装包iPhoneSimulatorSDK7_0.pkg,使用安装器安装此安装包,默认会安装在所选分区的/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.0.sdk目录下,完全退出Xcode5.1后将刚才安装的iPhoneSimulator7.0.sdk整个目录复制或移动到/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs目录下即可,重新启动Xcode5.1一般就可以使用相应版本的模拟器进行开发和调试了。

    离线安装还有一个简单的办法就是将以前安装过的旧版本的Xcode如Xcode5.0.2下面已经安装好了的iOS模拟器直接复制过来使用,目录位置都一样,都是在Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs里面。这样就不用再下载离线安装包了。顺便说一下,如果想用较早版本的SDK(Xcode5.1默认自带SDK是iOS7.1)来编译的话,也可以采用此直接复制的办法,但是目录稍有区别,SDK所在的目录是Xcode.app/Contents/Developer/Platforms /iPhoneOS.platform/Developer/SDKs,如Xcode5.0.2默认自带的SDK是iOS7.0.3,如果将Xcode5.0.2(dmg文件或者已经安装好的Xcode.app应用程序都可以)里面的SDK复制到Xcode5.1下面的SDK目录中,则在Xcode5.1的iOS工程设置就既可以选择Base SDK为iOS7.1也可以选择iOS7.0来编译工程。

    在线安装只能安装Xcode5.1默认支持的iOS模拟器版本,OS X Mavericks(10.9.x)下最低版本是iOS6.1,OS X Mountain Lion(10.8.x)下最低版本是iOS6.0,要安装在此之下的版本,需要采用离线安装的办法。

    但是离线安装也并不是能安装和运行所有低版本模拟器,经试验,OS X Mavericks(10.9.x)下离线安装后可以正常运行的最低iOS模拟器版本是iOS6.0,iOS5.1和iOS5.0模拟器都可以离线安装上,但是无法正常运行,会提示iOS SDK不支持模拟器,作者也不知道是否有解决办法,如果读者有解决办法,欢迎指教,但是作者使用iOS5.0.1版本的iPhone4硬件设备进行调试是没有问题的,也就是说在OS X Mavericks(10.9.x)下使用Xcode5.1对iOS6.0以下的版本只能使用硬件设备而不能使用模拟器进行调试。OS X Mountain Lion(10.8.x)下离线安装后可以正常运行的最低iOS模拟器版本是iOS5.0,在此之下的版本作者就没有去试验了。

    所以如果想在Xcode5.1下进行兼容iOS5的开发和调试,最好使用OS X Mountain Lion系统。

    以上就是作者为了方便安装Xcode5.1和使用iOS5模拟器进行开发调试进行的实践总结。

    至于如何在Xcode5.1上创建支持iOS5的工程,可以参考如下文章:

http://blog.csdn.net/xueer8835/article/details/17166615