POJ1274:The Perfect Stall(二分图最大匹配 匈牙利算法)

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17895   Accepted: 8143

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

n牛,m个房子,每一个牛都仅仅住在自己想住的房子里面,一个房子仅仅能住一个牛,问最多能够安排多少头牛入住。

像案例里的,第一头牛仅仅愿意住2,5。第二头牛。仅仅住2,3,4;第三头仅仅住1,5;第四头仅仅住1,2,5;第五头住2。

通过匈牙利算法可求得结果为4;

所以结果为4.

实现代码例如以下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int n, m;
int link[M];
bool MAP[M][M];
bool cover[M];
int ans;

void init()
{
    int num;
    int y;
    memset(MAP, false, sizeof(MAP));
    for(int i=1; i<=n; i++)
    {
        scanf("%d", &num);
        while( num-- )
        {
            scanf("%d", &y);
            MAP[i][y]=true;
        }
    }

}

bool dfs(int x)
{
    for(int y=1; y<=m; y++)
    {
        if(MAP[x][y] && !cover[y])
        {
            cover[y]=true;
            if(link[y]==-1 || dfs(link[y]))
            {
                link[y]=x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        ans=0;
        init();

        memset(link, -1, sizeof(link));
        for(int i=1; i<=n; i++)
        {
            memset(cover, false, sizeof(cover));
            if( dfs(i) )
                ans++;
        }
        printf("%d\n", ans);
    }

    return 0;
}






posted on 2018-01-17 14:23  yjbjingcha  阅读(209)  评论(0编辑  收藏  举报

导航