composer基本使用

一、Composer的安装

1、下载Composer

2、Composer安装

  1)、Composer安装前请确保已经安装了php;打开命令行窗口输入php -v可以查看php的当前版本号。

3、局部安装与全局安装

  局部安装正确安装完后,可以将 composer.phar 文件复制到任意目录(比如项目根目录下),然后通过 php composer.phar 指令即可使用 Composer 了

   全局安装:将 Composer 安装到系统环境变量 PATH 所包含的路径下面,然后就能够在命令行窗口中直接执行 composer 命令了

  注:composer  --version命令可以查看版本信息;

    composer selfupdate命令可以将composer更新到最新版本;

二、Composer基本使用

1、composer  update、composer  install 与 composer  require的区别

   Composer update:

    根据composer.json文件的包依赖关系将包更新到最新版本,并将版本依赖信息更新到composer.lock文件中;

  Composer update  vendor/package:

    从composer.json获取依赖关系,并将指定的package更新到最新版本,并将版本信息更新到composer.lock文件;

  Composer install:

    若有composer.lock文件,则据此直接安装,否则就根据composer.json文件安装最新扩展包和依赖;

  Composer require  package(new):

   项目有新的扩展包和依赖时,通过此命令添加,可以指定版本,例如:composer require package ~2.5;

  注意:composer update 命令会将所有包和依赖更新到最新版本,可能会对项目产生巨大伤害,需要慎用!!!

2、composer.json与composer.lock的区别

   composer.json:

   此文件用来声明项目中包之间的依赖关系以及一些元素信息;

   composer.lock:

   此文件用来锁定项目中包与依赖的版本信息,通常配合composer install来使用,确保项目中的成员得到一个版本的包与依赖关系;

  

 

 

posted @ 2018-01-18 11:35  壹然  阅读(4552)  评论(0编辑  收藏