AtCoder Grand Contest 012 A

A - AtCoder Group Contest


Time limit : 2sec / Memory limit : 256MB

Score : 300 points

Problem Statement

There are 3N participants in AtCoder Group Contest. The strength of the i-th participant is represented by an integer ai. They will form N teams, each consisting of three participants. No participant may belong to multiple teams.

The strength of a team is defined as the second largest strength among its members. For example, a team of participants of strength 152 has a strength 2, and a team of three participants of strength 323 has a strength 3.

Find the maximum possible sum of the strengths of N teams.

Constraints

  • 1≤N≤105
  • 1≤ai≤109
  • ai are integers.

Input

Input is given from Standard Input in the following format:

N
a1 a2  a3N

Output

Print the answer.


Sample Input 1

Copy
2
5 2 8 5 1 5

Sample Output 1

Copy
10

The following is one formation of teams that maximizes the sum of the strengths of teams:

  • Team 1: consists of the first, fourth and fifth participants.
  • Team 2: consists of the second, third and sixth participants.

Sample Input 2

Copy
10
1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000

Sample Output 2

Copy
10000000000

The sum of the strengths can be quite large.

题意:给3*N个数,3个一组,我们取每个组第二大的数出来相加,问最大能够是多少~

解法:排序,取2,4,6,8..就行

#include<bits/stdc++.h>
using namespace std;
#define ll long long
ll sum=0;
ll a[3*123456];
bool cmd(ll x,ll y)
{
    return x>y;
}
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=3*n;i++)
    {
       cin>>a[i];
    }
    int i=2;
    sort(a+1,a+1+3*n,cmd);
    while((n)--)
    {
        sum+=a[i];
        //cout<<a[i]<<endl;
        i+=2;
    }
    cout<<sum<<endl;
    return 0;
}

 

posted @ 2017-04-02 21:53  樱花落舞  阅读(359)  评论(0编辑  收藏  举报