CSU - 2031 Barareh on Fire (两层bfs)

传送门:

http://acm.csu.edu.cn/csuoj/problemset/problem?pid=2031

Description

The Barareh village is on fire due to the attack of the virtual enemy. Several places are already on fire and the fire is spreading fast to other places. Khorzookhan who is the only person remaining alive in the war with the virtual enemy, tries to rescue himself by reaching to the only helicopter in the Barareh villiage. Suppose the Barareh village is represented by an n × m grid. At the initial time, some grid cells are on fire. If a cell catches fire at time x, all its 8 vertex-neighboring cells will catch fire at time x + k. If a cell catches fire, it will be on fire forever. At the initial time, Khorzookhan stands at cell s and the helicopter is located at cell t. At any time x, Khorzookhan can move from its current cell to one of four edge-neighboring cells, located at the left, right, top, or bottom of its current cell if that cell is not on fire at time x + 1. Note that each move takes one second. Your task is to write a program to find the shortest path from s to t avoiding fire.

Input

There are multiple test cases in the input. The first line of each test case contains three positive integers n, m and k (1 ⩽ n,m,k ⩽ 100), where n and m indicate the size of the test case grid n × m, and k denotes the growth rate of fire. The next n lines, each contains a string of length m, where the jth character of the ith line represents the cell (i, j) of the grid. Cells which are on fire at time 0, are presented by character “f”. There may exist no “f” in the test case. The helicopter and Khorzookhan are located at cells presented by “t” and “s”, respectively. Other cells are filled by “-” characters. The input terminates with a line containing “0 0 0” which should not be processed.

Output

For each test case, output a line containing the shortest time to reach t from s avoiding fire. If it is impossible to reach t from s, write “Impossible” in the output.

Sample Input

7 7 2
f------
-f---f-
----f--
-------
------f
---s---
t----f-
3 4 1
t--f
--s-
----
2 2 1
st
f-
2 2 2
st
f-
0 0 0

Sample Output

4
Impossible
Impossible
1

Hint

Source

ATRC2017

 

分析:刚开始地图上有一些地方已经着火, 用'f'表示,初始的时候人在's'处,想要到't'处坐直升机逃跑。火势会蔓延,每过k秒大火

会蔓延到周围的八个网格,人每一秒只能选择上下左右四个方向中的一个方向移动。问是否能成功逃生,如果能最短时间是多少。

思路:这道题我们可以把火看成是墙壁, 和普通的bfs题不一样,这个“墙壁”会变化扩散。所以我们可以先bfs一次确定火势蔓延的

状态, 然后再bfs一次确定逃跑路线。第一次bfs记录下每一个网格被火势蔓延的时间time,在第二次bfs的时候只需要判断一下人走

到某一个网格的时间是否小于time即可。

  ps:火每k秒往8个方向扩展一次
   人只有四个方向

具体做法:

    两遍bfs,第一遍预处理每个点火烧到的时间,第二遍判断人是否能安全逃生
 code:

#include<stdio.h>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <cstdlib>
#include <queue>
using namespace std;
#define max_v 105
struct node
{
    int x,y,time;
};
int vis1[max_v][max_v];//火烧到没有
int vis2[max_v][max_v];//人走过没有
int tim[max_v][max_v];//每个点火烧到的时间
int dir[8][2]={1,0,0,1,-1,0,0,-1,1,1,-1,1,1,-1,-1,-1};
char G[max_v][max_v];
int n,m,k,mintime;//每k秒火向8个方向扩展一次
queue<node> q;
bool f(int x,int y)//有没有越界
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return true;
    return false;
}
void init()//初始化
{
    memset(vis1,0,sizeof(vis1));
    memset(vis2,0,sizeof(vis2));
    while(!q.empty())
    {
        q.pop();
    }
}
void bfs1()//火 主要是得到火烧到每个点的时间
{
    node p,next;
    while(!q.empty())
    {
        p=q.front();
        q.pop();

        for(int i=0;i<8;i++)
        {
            next.x=p.x+dir[i][0];
            next.y=p.y+dir[i][1];
            next.time=p.time+k;//注意理解

            if(f(next.x,next.y)&&vis1[next.x][next.y]==0)//火没有越界且没有烧到
            {
                vis1[next.x][next.y]=1;
                tim[next.x][next.y]=next.time;
                q.push(next);
            }
        }
    }
}
bool bfs2()//
{
    node p,next;
    while(!q.empty())
    {
        p=q.front();
        q.pop();

        if(G[p.x][p.y]=='t')
        {
            mintime=p.time;
            return true;
        }
        for(int i=0;i<4;i++)
        {
            next.x=p.x+dir[i][0];
            next.y=p.y+dir[i][1];
            next.time=p.time+1;//人每走一步时间加1

            if(f(next.x,next.y)&&next.time<tim[next.x][next.y]&&vis2[next.x][next.y]==0)//没有越界,当前时间小于火烧到时间 ,点人没有走过
            {
                vis2[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
    return false;
}
int main()
{
    node temp;
    while(cin>>n>>m>>k,n&&m&&k)
    {
        int num=0;
        init();
        node s,f;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>G[i][j];
                if(G[i][j]=='f')
                {
                    tim[i][j]=0;
                    vis1[i][j]=1;
                   temp.x=i;
                   temp.y=j;
                   temp.time=0;

                    q.push(temp);//将所有火入队,得到每个点火烧到的时间
                    num++;//火的个数
                }
                if(G[i][j]=='s')
                {
                    s.x=i;
                    s.y=j;
                    s.time=0;
                    vis2[s.x][s.y]=1;//人的起点
                }
                if(G[i][j]=='t')
                {
                    f.x=i;//人的终点
                    f.y=j;
                }
            }
        }
        if(num==0)//没有火!!!
        {
            mintime=abs(s.x-f.x)+abs(s.y-f.y);
            cout<<mintime<<endl;
            continue;
        }

        bfs1();//得到每个点的起火时间

        while(!q.empty()) q.pop();

        q.push(s);//人的起点入队
        if(bfs2())
        {
            cout<<mintime<<endl;
        }
        else
        {
            cout<<"Impossible"<<endl;
        }
    }
    return 0;
}

 

 

posted @ 2018-07-30 18:26  西*风  阅读(281)  评论(0编辑  收藏  举报