HDU 1372 Knight Moves(最简单也是最经典的bfs)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1372

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13384    Accepted Submission(s): 7831


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

 

Sample Input
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

 

Sample Output
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
 

 

Source
 

 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1253 1072 1242 1240 1548 
 
分析:
给你起点和终点坐标,只能往8个方向走(类似马走斜日)
问你最短的步数
最经典的bfs问题
很多问题bfs都是这个模板,只不过剪枝条件发生了变化
第一次写bfs,纪念意义很大啊
code:
#include<bits/stdc++.h>
using namespace std;
#define max_v 10
int G[max_v][max_v];
int dir[8][2]= {{1,-2},{2,-1},{2,1},{1,2},{-1,2},{-2,1},{-2,-1},{-1,-2}};
int step;
int sx,sy,fx,fy;
struct node
{
    int x,y,step;
};
void bfs()
{
    memset(G,0,sizeof(G));
    queue<node> q;
    node p,next;
    p.x=sx;
    p.y=sy;
    p.step=0;
    G[p.x][p.y]=1;
    q.push(p);

    while(!q.empty())
    {
        p=q.front();
        q.pop();

        if(p.x==fx&&p.y==fy)
        {
            step=p.step;
            return ;
        }

        for(int i=0; i<8; i++)
        {
            next.x=p.x+dir[i][0];
            next.y=p.y+dir[i][1];

            if(next.x>=1&&next.y>=1&&next.x<=8&&next.y<=8&&G[next.x][next.y]==0)
            {
                next.step=p.step+1;
                G[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
}
int main()
{
    char c1,c2;
    int y1,y2;
    while(~scanf("%c%d %c%d",&c1,&y1,&c2,&y2))
    {
        getchar();
        sx=c1-'a'+1;
        sy=y1;
        fx=c2-'a'+1;
        fy=y2;
        bfs();
        printf("To get from %c%d to %c%d takes %d knight moves.\n",c1,y1,c2,y2,step);
    }
    return 0;
}

 

 
posted @ 2018-07-22 17:49  西*风  阅读(2218)  评论(0编辑  收藏  举报