Cats and Fish (模拟)

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1

Sample Output

1 0
0 1
0 3
要注意一下 有一只猫开始吃了 那他就把这条鱼占了 别的猫即使比他速度快也不能吃它的这条
所以先照顾吃了一半的 s来统计个数 把m减去s就是还有多少条完整的鱼 再分给其他没鱼吃的猫咪
最后统计吃完手上这条鱼的猫数 m--
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int i,j,n,m,x;
    int a[1005],b[1005];
    while(~scanf("%d%d%d",&m,&n,&x))
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]),b[i]=0;
        sort(a,a+n);
        for(j=1;j<=x;j++)
        {
            int s=0;
            for(i=0;i<n;i++)
                 if(b[i]!=0)s++,b[i]++;//吃了一半的
            int yu=m-s;//还剩多少没吃
            for(i=0;i<n;i++)
            {
                if(yu<=0)break;
                if(b[i]==0)//没吃的
                {
                    b[i]++;
                    yu--;
                }
                if(yu<=0)break;
            }
            for(i=0;i<n;i++)
                if(a[i]==b[i])m--,b[i]=0;//吃好了的
        }
        int s1=0;
        for(i=0;i<n;i++)
            if(b[i]!=0)s1++;//吃了一半的
        cout<<m-s1<<" "<<s1<<endl;
    }
    return 0;
}

 

posted @ 2019-08-19 14:47  -第4题-  阅读(264)  评论(0编辑  收藏  举报