opencv多版本安装

使用命令查看当前的opencv版本:

pkg-config --modversion opencv

自带的是opencv-2.4.9

安装opencv3.1

安装opencv的依赖项

sudo apt-get install build-essential libgtk2.0-dev libvtk5-dev libjpeg-dev libtiff4-dev libjasper-dev libopenexr-dev libtbb-dev

进入解压后的opencv安装包,新建目录,目录名为build,并进入该目录

mkdir build && cd build

输入命令

sudo mkdir -r /usr/local/opencv310
cmake -D CMAKE_BUILD_TYPE=RELEASE -D WITH_TBB=ON -D WITH_V4L=ON -D WITH_CUBLAS=0 -D WITH_CUDA=0 -D WITH_CUFFT=0 -D CMAKE_INSTALL_PREFIX=/usr/local/opencv310 ..
make
sudo make install

在这里,opencv3.3的安装目录放在了/usr/local/opencv310文件夹,同时注释了和CUDA相关的部分(当前安装的CUDA7.5,在编译的时候编译不过去 )

紧接着需要配置下文件,通过修改bashrc文件来设置PKG_ CONFIG_PATH(后来发现好像还需要改一下LD_LIBRARY_PATH)<引用>

sudo gedit ~/.bashrc

在文件末尾加上

export PKG_CONFIG_PATH=/usr/local/opencv310/lib/pkgconfig
export LD_LIBRARY_PATH=/usr/local/opencv310/lib

保存之后,再使用命令

source ~/.bashrc

这时候使用命令,opencv版本已经变成3.1了

pkg-config --modversion opencv

当你使用的是cmake工具时,在CMakeLists.txt中加入路径即可使用opencv3.1

set(OpenCV_DIR /usr/local/opencv310/share/OpenCV)
find_package(OpenCV 3.1 REQUIRED

include_directories(SYSTEM ${OpenCV_INCLUDE_DIRS} /usr/local/opencv310/include)
find_package("/usr/local/opencv310/include/opencv2")

当你想返回使用opencv2时,将find_package(OpenCV 3.1 REQUIRED )换成find_package(OpenCV REQUIRED )即可,并将该代码上面一行和下面俩行删除即可。

 

posted @ 2018-04-30 18:28 amazingym 阅读(...) 评论(...) 编辑 收藏