打开网站显示Your MySQL server version for the right syntax to use near 'WITH ROLLUP' at line X错误怎么办|已解决
Your MySQL server version for the right syntax to use near 'WITH ROLLUP' at line X
问题:使用 WITH ROLLUP 等语法时提示版本不兼容
原因:使用了高版本 MySQL 支持的语法(如 WITH ROLLUP、CTE 公用表表达式),但当前 MySQL 版本过低(如 5.5 不支持部分 5.7 语法)
解决方案:
1. 升级 MySQL 版本至支持该语法的版本(如 5.7+);
2. 替换为低版本兼容语法(如用 UNION ALL 替代 WITH ROLLUP 实现汇总)

扫码添加技术【解决问题】
专业解决各种疑难杂症,您有任何问题都可联系我们技术人员。
本文来自博客园,作者:可有仙子迎风立,转载请注明原文链接:https://www.cnblogs.com/xztime/p/19704695

浙公网安备 33010602011771号