打开网站显示"Cannot add foreign key constraint"错误怎么办|已解决
Cannot add foreign key constraint
问题:添加外键约束失败
原因:外键字段与引用字段类型 / 长度不一致(如 INT (10) 引用 INT (11))、引用的字段不是主键 / 唯一索引、两张表的存储引擎不一致(如一张 MyISAM 一张 InnoDB)
解决方案:
1. 确保外键和引用字段类型 / 长度 / 字符集完全一致;
2. 给引用字段添加主键 / 唯一索引:
ALTER TABLE 引用表 ADD PRIMARY KEY (字段名);;3. 统一两张表的存储引擎为 InnoDB:
ALTER TABLE 表名 ENGINE=InnoDB;
扫码添加技术【解决问题】
专业解决各种疑难杂症,您有任何问题都可联系我们技术人员。
本文来自博客园,作者:可有仙子迎风立,转载请注明原文链接:https://www.cnblogs.com/xztime/p/19704666

浙公网安备 33010602011771号