HDU 3038 How Many Answers Are Wrong (并查集)

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3404    Accepted Submission(s): 1310


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

 

Output
A single line with a integer denotes how many answers are wrong.
 

 

Sample Input
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

 

Sample Output
1
 
 
 
传说中的带权并查集。实际上,可以输入的x,y,w可以理解成y+1比x大w,所以每次把x,y+1存起来,遇到sum[x]就表示x到根节点的和,根节点在后面。每次更新的方法就是用上一篇博文里的矩阵来更新。
#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
using    namespace    std;

const    int    SIZE = 200005;
int    FATHER[SIZE],SUM[SIZE];
int    N,M,ANS;

void    ini(void);
int    find_father(int);
void    unite(int,int,int);
int    main(void)
{
    int    x,y,w;

    while(scanf("%d%d",&N,&M) != EOF)
    {
        ini();
        while(M --)
        {
            scanf("%d%d%d",&x,&y,&w);
            y ++;
            unite(x,y,w);
        }
        printf("%d\n",ANS);
    }

    return    0;
}

void    ini(void)
{
    ANS = 0;
    for(int i = 1;i <= N + 3;i ++)
    {
        FATHER[i] = i;
        SUM[i] = 0;
    }
}

int    find_father(int n)
{
    if(n == FATHER[n])
        return    n;
    int    temp = FATHER[n];
    FATHER[n] = find_father(FATHER[n]);
    SUM[n] = SUM[n] + SUM[temp];
    return    FATHER[n];
}

void    unite(int x,int y,int w)
{
    int    fx = find_father(x);
    int    fy = find_father(y);

    if(fx == fy)
    {
        if(SUM[x] - SUM[y] != w)
            ANS ++;
        return    ;
    }
    
    if(fx < fy)
    {
        FATHER[fx] = fy;
        SUM[fx] = -SUM[x] + w + SUM[y];
    }
    else
    {
        FATHER[fy] = fx;
        SUM[fy] = -SUM[y] - w + SUM[x];
    }
}

 

posted @ 2015-05-29 17:16  Decouple  阅读(204)  评论(0编辑  收藏  举报