1002. A+B for Polynomials (25)——PAT (Advanced Level) Practise

题目信息:

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

代码如下:

#include <stdio.h>

int main()
{
	int  k, i, r;
	char check[1001];
	float arr[1001], tmp;
	while (scanf("%d", &i) != EOF)
	{
		for (r = 0; r < 1001; ++r)
			check[r] = arr[r] = 0;
		for (; i > 0; --i)
		{
			scanf("%d", &k);
			scanf("%f", &arr[k]);
			check[k] = 1;
		}
		scanf("%d", &i);
		for (; i > 0; --i)
		{
			scanf("%d", &k);
			scanf("%f", &tmp);
			if (check[k])
				arr[k] += tmp;
			else
				arr[k] = tmp;
			check[k] = 1;
		}
		i = 0;
		for (r = 0; r < 1001; r++)
		{
			if (check[r] && arr[r] != 0)
				i++;
		}
		printf("%d", i);
		if (i)
			printf(" ");
		for (r = 1000; r >= 0; r--)
		{
			if (check[r] && arr[r] != 0)
			{
				printf("%d %.1f", r, arr[r]);
				if (--i)
					printf(" ");
			}
		}
		printf("\n");
	}
	
}


posted @ 2014-09-23 17:07  闲云阁  阅读(146)  评论(0编辑  收藏  举报