1017 Queueing at Bank (25 分)
 

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (104) - the total number of customers, and K (100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题目大意:银行中有K个窗口提供服务,窗口后有一条黄线,如果窗口前有人,客户必须在黄线后等待。每个客户最多被服务1小时。现在有N名客户,给出每名客户的到达时间和处理时间,问这N名客户的平均等待时间是多少?注意,8:00之前到达的用户需要一直等到8:00,在17:00之后到达的客户不再被提供服务。

解题思路:这道题和1014差不多,都是使用队列结构的模拟题。这道题的核心是使用优先队列。首先按照客户到达时间为客户排序,然后依次处理每个用户。用一个优先队列存储窗口可以提供服务的时间,如果最早结束服务的窗口时间早于当前顾客到达的时间,那么不需要等待,否则用队首元素保存的时间减去顾客到达的时间代表等待时间。然后更新该窗口可提供服务的时间。

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn =10005;
struct person
{
    int com,time;
    bool operator<(const person&a)const
    {
        return com<a.com;
    }
}p[maxn];
int n,k,cnt,total;
int main()
{
    //freopen("input.txt","r",stdin);
    scanf("%d %d",&n,&k);
    for(int i=1;i<=n;i++)
    {
        int hh,ss,mm,tt;
        scanf("%d:%d:%d %d",&hh,&mm,&ss,&tt);
        int sum = hh*3600+mm*60+ss;
        if(sum>61200) continue;
        p[++cnt].time = tt*60;
        p[cnt].com = sum;
    }
    sort(p+1,p+cnt+1);
    priority_queue<int ,vector<int>,greater<int> > q;
    for(int i=1;i<=k;i++)
        q.push(28800);
    for(int i=1;i<=cnt;i++)
    {
        if(q.top()<=p[i].com)
        {
            q.push(p[i].com+p[i].time);
            q.pop();  // 换人
        }
        else
        {
            total+=q.top()-p[i].com;
            q.push(q.top()+p[i].time);
            q.pop();
        }
    }
    (!cnt)?printf("0.0\n"):printf("%.1f\n",((double)total/60.0)/(double)cnt);
    return 0;
}