1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题目大意:给出电话公司每个时间段长途电话的价格,然后再给出若干条通话信息。通话信息包括用户名,时间,状态(接通还是挂断)。根据这些把一个用户一个月内所有的通话记录全部打印出来,并算出总的花费。注意,不成对的通话信息是无效的。题目保证总有成对的通话信息。输出时按照的用户字母序排序。

解题思路:这是一个排序问题。排序对象是记录,记录包括用户信息,时间,状态,为计算时间方便,在结构体中添加month,day,hour,minute。先按照姓名排序,然后再按照时间排序。然后再在排好序的序列中遍历,找姓名相同而且成对的记录。同时使用map容器,关联用户和有效的记录。最后计算总费用。为计算方便,可用一个函数计算从月初开始到当前时间,一直打长途的花费。分别代入挂断时间和接通时间并作差,即可得到这次通话的费用。

参考代码:

 

#include <iostream>
#include<string>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
struct record
{
    string name;
    int time;
    int state;  // 状态
    int month,day,hour,minute;
};
int toll[25]={0};  // 话费数组
bool cmp(record a,record b)
{
    return (a.name==b.name)?(a.time<b.time):(a.name<b.name);
}
double billFromZero(record call)
{
    double total = toll[call.hour]*call.minute+toll[24]*60*call.day;
    for(int i=0;i<call.hour;i++)
    {
        total +=toll[i]*60;
    }
    return total/100.0;
}
int n;

int main()
{
    //freopen("input.txt","r",stdin);
    for(int i=0;i<24;i++)
    {
        scanf("%d",&toll[i]);
        toll[24]+=toll[i];    //为计算方便,在toll[24]中存储一天的通话费用/60;
    }
    scanf("%d",&n);
    vector<record>R(n);
    for(int i=0;i<n;i++)
    {
        cin>>R[i].name;
        scanf("%d:%d:%d:%d",&R[i].month,&R[i].day,&R[i].hour,&R[i].minute);
        R[i].time = R[i].day*1440+R[i].hour*60+R[i].minute;
        string temp;
        cin>>temp;
        R[i].state = (temp=="on-line")?1:0;
    }
    sort(R.begin(),R.end(),cmp);
    map<string ,vector<record> >custom;
    for(int i=1;i<n;i++)
    {
        if(R[i].name==R[i-1].name&&R[i-1].state==1&&R[i].state==0)
        {
            custom[R[i-1].name].push_back(R[i-1]);
            custom[R[i].name].push_back(R[i]);
        }
    }
    for(auto it:custom)  //开始计算时间
    {
        cout<<it.first;
        vector<record>temp = it.second;
        printf(" %02d\n",temp[0].month);
        double total=0.0;
        for(int i=1;i<temp.size();i+=2)
        {
            double m = billFromZero(temp[i])-billFromZero(temp[i-1]);
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", \
            temp[i - 1].day, temp[i - 1].hour, temp[i - 1].minute, temp[i].day, temp[i].hour, temp[i].minute, temp[i].time - temp[i - 1].time,m);
            total+=m;
        }
        printf("Total amount: $%.2f\n",total);
    }
    return 0;
}